Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to hide that you are connected to a computer via Remote Desktop or Virtual PC? Software (Cisco AnyConnect VPN Client, to be exact) has the ability to tell if you are connected to the PC via remote desktop or via virtual PC. Is there a way in Windows XP to hide the face that you are connected via Remote Desktop or Virtual PC?

Here's the background story:

My company uses a Cisco VPN solution whereby we use the Cisco AnyConnect VPN Client to connect. I believe this uses an SSL VPN, but I'm not exactly sure.

When I installed Windows 7 64-bit, I soon discovered that the Cisco AnyConnect VPN Client would not work (although it did work on Windows 7 32-bit). When I try to install client from the web portal, I get a message that reads:

This computer does not match the location settings. You can not continue. Contact your IT administrator for more information.

I then installed Windows XP Mode and Windows Virtual PC from my 64-bit Win 7 machine. I was actually able to get farther into the set up process and the software even installed. Whether I run the software from the virtual machine directly, or I run it "virtualized" from Windows 7 under "Windows XP Mode," I get the same error message. I'm actually able to put in my VPN information, username, and password, but when I click Conenct, I get the following message:

Secure VPN via remote desktop is not supported.

Question: Is there a way to "trick" the VPN client by changing something in Windows XP so that it does not know that I'm connected to a virtual PC or via Remote Desktop?

Any help would be greatly appreciated.

share|improve this question
    
So, did you contact your "System administrator" and possibly, get the latest version? (which apparently supports 7: cisco.com/en/US/prod/collateral/vpndevc/ps6032/ps6094/ps6120/…) –  Grizly Feb 23 '10 at 3:24
1  
@Grizly I did contact my sys admin. At the time, Anyconnect supposedly did support 64-bit Windows, except for the Secure Desktop part of AnyConnection. Secure Desktop didn't support 64-bit operating systems. Perhaps that's changed in the latest version. However, I'm no longer working there so it's not a huge deal for me anymore =). –  Ben McCormack Mar 4 '10 at 1:36
add comment

1 Answer

Even though this is an ancient question, I ran into the same problem and I'll leave my solution here for Google to find. I'm using XP Mode because I don't want to install commercial VPN clients on my actual machine, they always mess things up with stupid security features.

The way to get around the weird anti-RDP setting is to "Disable Integration Features" from the Tools menu in the VM. Apparently that makes the VM viewer not use RDP, hence avoiding this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.