Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been a TextPad user for years, and when you install it, it adds an item to the context menu in explorer called "TextPad" that will open any file with textpad, regardless of the extension (whether or not its readable is another matter of course). Now, I could be remembering wrong, but I recall on older computers, if you opened a file with this method, it would open any such files in the already-running instance of TextPad. Now, when I do this, it seems to open a new copy of TextPad every time I open a new file. I'd perfer it to use the same instance. How can I enable this behavior?

share|improve this question

6 Answers 6

up vote 9 down vote accepted

There is an option in TextPad to only allow one instance to run:

Configure > Preferences > General > [ ] Allow multiple instances to run

Uncheck that box and click OK.

Now when opening any file in Textpad it will use the same instance.

share|improve this answer

I used to use Textpad years ago, and used it for many years. I don't have it installed now, so I can't readily look it up, but is there an option in the Settings to "Allow one instance" or something of that nature? I.e. When that item is selected, Textpad will only run a single instsance, or when unchecked it can open multiple Textpads, plural.

@Eric beat me to the actual config entry. I went to look at an old machine, and I do have it installed still. The config item he posted is the one I was trying to recall, and it's the inverse of what I initially described. +1 @Eric.

share|improve this answer

In Windows 7, associate .txt directly to Textpad rather than "Replace Notepad".

share|improve this answer
  • Open Textpad, go to Configure in the menu then Preferences.

  • Context Menu is checked for some strange reason. Uncheck the box and then close the interface.

  • Open Textpad again and check the same box.

  • Now it's in the context menu for all files.

It must fail in Windows 7 upon the original install.

share|improve this answer
    
Hi and welcome to SU! Unfortunately, your answer does not address the OP's problem which is not that the menu entry is missing for some files but that the files open in a new instance of TextPad instead of in the already running one. –  terdon Nov 30 '12 at 12:29

You must be running Windows 7. I have had the same problem under MS's new OS, both at work and home. Too bad MS broke more things than they fixed. Helios will have to find a fix for MS's screw-up. I was just Googling to see if anyone had figured out how to fix this.

share|improve this answer
    
I had the same problem on both Windows 7 and XP boxes, but Eric's fix seems to do the trick –  DrFredEdison Jan 1 '10 at 19:43

What if you want to use more instances, but still wants files you click on in explorer be opened in the already running instance?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.