Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Mavericks, Apple introduced a "feature" where if you hover at the bottom of any screen the dock pops up on that screen.

This is disrupting my workflow as I am constantly having the dock pop up when I don't want it to and then I have to go to another window and hover at the bottom for several seconds to get it to go away so I can click on what I was trying to in the first place.

I don't want the dock to move; I want it to stay on the bottom of my right-most monitor like it always has. How can I adjust this in OSX Mavericks?

share|improve this question
2  
I think this is also mentioned here: After a month of use, we dish out our biggest gripes with OS X Mavericks –  slhck Nov 28 '13 at 16:50

7 Answers 7

Just hold your mouse at the bottom of the monitor where you want the dock to be.

I know this sound really weird, but it works.

share|improve this answer
3  
this is exactly what I was looking for, thanks! –  Beasterfield Nov 29 '13 at 12:45
7  
This doesn't seem to work consistantly - I don't know what behavior it's expecting... it doesn't always work for me like I'd expect. –  CS. Jan 8 at 21:07
5  
@CS. in my case I need to slightly move the mouse further down against the edge of the display for the dock to jump back, not merely to hold the mouse there –  GJ. Jan 22 at 13:56
23  
This does not address the user's question. while this is the answer to how do you get the dock to move from one monitor to another, what the questioner wants is to PREVENT this behavior and lock the dock to a single monitor. –  Chuck van der Linden Mar 3 at 18:51
1  
@Lewis Commons, as Chuck has also commented, the question was about preventing the dock from moving. Your answer is for a different question. Please read the question. –  A-B-B Apr 10 at 17:58

This is very easy.

Go to System Preferences > Mission Control, then deselect the option "Displays have separate Spaces"

share|improve this answer
    
Nice, that worked. Doesn't seem like they should be related but I'll gladly trade the Spaces flexibility to get rid of this annoyance. –  Brad Dwyer Oct 25 '13 at 16:59
49  
Unfortunately this turns off all of the new multi-monitor features (multiple menu bars, single monitor full-screen mode, etc). Is there a way to only prevent the dock from jumping? –  Brad Dwyer Oct 25 '13 at 18:08
1  
I want my Spaces to be separate, though! Apple needs to implement Dock-Screen affinity. –  fatuhoku Aug 10 at 20:13

An alternative, as suggested by MacLife, is to put the Dock on the right or left and then it won't move. But hopefully in a future iteration the Dock can be kept on the bottom and only on one monitor.

share|improve this answer
    
Good thinking... –  fatuhoku Aug 10 at 20:14

There is to my knowledge no good solution to this issue. For some reason the good folks at apple have conflated the top of screen menu with the dock, and if you get one on any screen, you also get the other. Without resorting to a third party app, there is no way to have menu bars in each screen but lock the dock to the bottom of a single screen. (I would be glad to be proven wrong here, but I've looked a bunch and not found a way)

Details:

If monitors are arranged 'stacked' then the dock will be at bottom of the bottom monitor. However, few of us arrange this way and those who do would most likely not be asking this question.

If monitors are side by side, you can move it ALL-THE-WAY to the left or right and it will stay there, but that is not as requested (or as many people desire) at the bottom of a single screen.

You can hide it, so it won't obscure stuff, but it will still move around whenever mouse is 'bottomed' on a screen for small period of time. This might be the 'best' solution, provided you like a hidden dock, as you can then easily access it on any screen, but it is not in the way or annoying you by being seen to 'jump around'. It is rather there when you want it, and hidden otherwise. (I strongly suspect anyone doing usability testing had things set this way and thought it was just great, and why would anyone want to see the dock all the time anyway... )

You can turn off the each monitor is own space stuff, but then you lose having the menu bar at the top of each screen. Obviously folks have different perspectives, but one thing I HATED about mac's multi-monitor support was having to move to an entirely different screen to access the top-screen menu for a program open on a different screen. This was something I really like about mavericks (multiple menu bars) but sadly it seems to come at the price of the annoying jumping dock

If don't want a hidden dock, and you want top menus bars on each screen, and dock fixed at the bottom, the best workaround appears to be to basically disable all the new mavericks stuff by disabling 'each screen is its own space' Then get a utility like "Second Bar" which while discontinued is still available, as a way to get a menu bar at the top of each screen. I used Second Bar a lot with mountain lion and found it to work well (although you need to have a second renamed copy of the app for each additional screen) I have not used it with Mavericks so cannot say how well it does or does not work.

share|improve this answer

Alternatively, you could go to -

System Preferences > Dock > Automatically Show and Hide Dock

While this is not the exact solution you were looking for, it does solve the problem of the dock sticking and getting in the way. I was annoyed by the same thing and eventually used this option as my resolution.

share|improve this answer

There is a workaround for the disappearing dock. If you set whatever is in your 2nd screen to full screen and then maximize it. It will leave your dock in place where you want it the whole time. Though I only find this beneficial when using a browser in the 2nd screen.

share|improve this answer
1  
This doesn't really work. The dock still moves freely. I tested with Google Chrome and VirtualBox maximized. –  A-B-B Apr 10 at 18:10

This is my way:

System Preference > Dock > Position on screen: Right if you want it to stay on the right-most monitor, choose Left if you want it to stay on the left.

The dock then shown vertically. It is even better, monitors have more horizontal real estate.

share|improve this answer
    
This would've actually worked if the dock could be placed in-between the two monitors at the edge of either one. But it doesn't let you dock there. Instead it is docked on the far extreme left or right where I don't want it. –  A-B-B Apr 10 at 18:23
1  
Unfortunately this doesn't work well for folks with 3 or more monitors. –  ylluminate Jul 9 at 15:34

protected by Community Apr 17 at 12:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.