Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On Vista Home Premium SP1, when I try:

  • Start
  • Control Panel
  • network and sharing center
  • File Sharing
  • Turn On File Sharing
  • Apply

I get a very windows 95-esque dialog that says "The parameter is incorrect." With an OK button. No other explanation. Any ideas on what I should do enable file sharing? I get the same result if I try to turn on Network discovery.

share|improve this question
up vote 0 down vote accepted

Make sure the user account you are logged in with has a password on it. If it doesn't, crate one and then restart (or at least log out and in again). I had this exact problem with a Vista machine trying to enable Public Folder sharing and that is what finally fixed it for me.

share|improve this answer
    
Thanks rymo -- I've upgraded all of my vista machines to Win7 -- so I can't test it. I'll all it answered though -- thanks! – JohnnyLambada Jan 14 '11 at 4:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .