Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm Debian beginner & GUI guy in a bit of trouble?

Can't login as sudo/gksu/root/su nor as (main/super)user after removed user password via Gnome-user-settings.


History of actions

(Probably irrelevant though)

  • Installed Debian "Jessie" GNU/Linux with xFce GUI (en-US) as only OS. HardWare is ThinkPad w510.
  • Skipped root user password in setup, to get sudo for superuser easily.
  • Logged in (as always had) with Gnome (3.4.x), not once with xFCE. (installed Xfce. Installed xFce only to achieve more control (easier management) over packages this way, to set-up gnome much more by mine likes.
  • Added more jessie repros (same ones as in Wheesy stable by default but for Jessie as, Jessie only had repros for security updates by default).
  • Installed lots of gtk(3) & gnome(3) based soft; (- restarted again after this)
  • Installed propietary graphics card driver for mine nvidia quadro. (- restarted once again after that one)
  • Installed more stuff related to mine work/school/devel.

The actual problem

  • Had a plan to restart again, but wanted to set up auto-login first, instead set user password to none (don't ask why / perhaps caused by being awake for a looooong time), noticed it, and set also to auto-login, but couldn't undo mine previous mistake to create new password for me.

  • As mine password is set to none I would have expected that simply return in pass prompt for emty password field would do, but it won't authenticate. I tried Alt+F2 "gksu gedit" as well as: sudo wget "https://www.some-page.eu/file.ext" and "su" in terminals, none has applied (quite logical actually - as I'm sudoer and highest ranked super user, besides only user in computer).

Current stand

  • Everything worked & still works nice after this accident, besides this password prompts part.
  • To spoked to log-out nor restart.
  • Synaptic package-manager is still open with root rights (only one, that has left open prior to the issue and not closed since, just in case).

Goggled for help and read some manuals/faqs/how-tos - mostly lead to sudoers file management, but not found one specifically for mine issue - so still not any smarter.


Really hope, that I don't have to redo OS inst all over again, by just one stupid mistake.


Thanks for your reply :-)

share|improve this question
    
So you can still login? Can you get to a terminal and do passwd to set a new password? –  Paul Oct 26 '13 at 2:52
    
never loged out after this. but while being loged in, no mater where (various graphical & terminal password promts) nor by whom (me, root & me as root/sudo) asked by, password isn't valid. By mine logic, I should enter nothing for mine pass as no user password is set. –  Janar Oct 26 '13 at 9:38
    
Yep, passwd did the trick :D, also terminal sudo verifies :). alt+f2 'gksu gedit' didn't :(, but I suspect its fixed after logout/reboot ;). –  Janar Oct 26 '13 at 10:15
    
@Janar, a trivial point but in English "mine" and "my" are different words, and your question would be a little easier to understand for a native speaker if you replaced "mine" almost throughout with "my". (See ell.stackexchange.com/questions/24722/… for explanation of how they work, also 'you' vs 'yours' etc...) –  John Lawrence Aspden Nov 10 at 0:35

1 Answer 1

up vote 1 down vote accepted

change your user's password when booting to `recovery mode' - it will show you root shell after boot.

to change password use `passwd username' and then reboot again to normal mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.