Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I seem to have some sort of https time-out problem with browsers in Windows 7.

Windows 7 seemed to work just fine until a few weeks ago, when (among other things) I installed Windows EMET. Stupid me. That slowed everything in Windows down to a crawl (the computer became almost unusable), so I uninstalled it. Then I discovered the browser/https problem.

If I start up a browser and open an https site (e.g. http://www.google.com, which transforms itself into https://www.google.com) it opens OK (Google is my default home page). If I then browse to other https sites (either by clicking on a Google search result, or by clicking on a saved Favorite), the computer will connect OK until after about 90 - 120 seconds have elapsed from my starting up the browser -- then either the browser hangs up (if I'm using IE9), or I get a message saying that it's given up because the site didn't respond and so it's timed out (if I'm using Chrome or Comodo's Dragon, which is a Chrome derivative). From that point I can still access http sites without a problem, but not https sites -- until I exit from the browser and start up afresh, and then the timeout cycle starts all over again.

This is a real problem when shopping, for example; by the time I get to checkout, the timeout prevents me from getting to the end of the chain of checkout windows and so I can't complete the transaction. All three browsers exhibit the problem. I've tried shutting down the firewall; that makes no difference.

I thought at first that this was an ISP timeout or a WiFi timeout. It's definitely not; I'm not using WiFi, and other computers in the household (using Windows 7, Windows XP) don't exhibit this problem. Also, IE8 running in a virtual XP window on this same Windows 7 machine works just fine with https -- no timeout.

I don't think I have a virus; I've used several antivirus programs (incuding Comodo) and none could find anything.

My first thought was of course to do a System Restore. That's when I discovered that Defraggler64 v 2.15 had wiped out all my System Restore points (assuming that it wasn't another side effect of EMET -- it may have been, because for a while I couldn't retain any new System Restore Points; those kept mysteriously disappearing. Or it might have been 64-bit CCleaner v 3.15.16, although the developers deny that, and I don't see how that could wipe out new SRPs after I quit using it.) Ok, I fixed the System Restore problem, but the https timeout is still there.

Reinstalling IE9 or installing IE10 doesn't seem likely to fix the problem; to repeat: it arises with Chrome and Dragon too.

In the worst case, I could go back to a pretty old System Image, but that would be a lot of work (I'd have to reinstall all the subsequent Windows updates, for one thing). Which reminds me of another interesting problem that cropped up around the same time; now I can't (manually) get Windows Update to tell me whether I'm lacking any important updates; I never get a response from the Microsoft site. However, all the updates do seem to be getting installed, so I can live with that.

Can anyone please suggest where the timeout is in Windows 7 (64-bit), and how I can change it?

share|improve this question
    
Have you tried using a different DNS server in your network settings? –  Ƭᴇcʜιᴇ007 Oct 26 '13 at 20:49
    
The bad computer (IE9) was set to pick its own DNS automatically. The good computer (IE10) uses the Comodo DNS. Tried both the Comodo DNS and OpenDNS settings on the bad computer; nothing changes. New details: all the 3 browsers start a ~30-second timeout when the first HTTPS site is opened in the session. For 30 s, other HTTPS sites can be opened (e.g. Google followed by Google News); after 30 s, they can't but HTTP sites can. Then after a few minutes (15?) some HTTP sites start to hang up also. Is there a timer someplace in that pile of rotting spaghetti code that could be causing this? –  Incognito771 Nov 11 '13 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.