Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working from home and connected to my work's vpn.

I have tried to connect to the work db with sql developer (the latest version and the previous version) on the following environments:

mac os x 10.8.5 (with sql developer launched and installed directly on the iMac.
sql developer launched and installed directly on a vm on same computer (guest Ubuntu 12.04 LTS)
sql developer launched and installed directly on a vm on same computer (guest Windows 7.0 Professional)

I get Status Failure Test Failed : IO Error - The Network Adapter could not establish the connection.

I have read dba forums and googled and the most common suggestion is that the oracle listener is not up and running. I can conclusively say this is not the case because I have the option of using remote desktop and accessing the oracle db in question on my work computer. If the listener was down, according to my DBA, no one would be able to connect. My sysadmin and dba are stumped so I assume it is something unique to my home system.

The reason I do not want to continue with the remote desktop workaround is because remote desktop has an annoying (infuriating often) lag.

share|improve this question
    
If you are using a basic connection, make sure your host has the fully qualified domain name. I had the same issue and using the FDQN resolved the issue for me. –  Wolf Oct 27 '13 at 0:46
    
I've tried using a Basic connection and TNS connection (all relevant data points verified by my sysadmin). Both had no luck. –  lostinthebits Oct 27 '13 at 1:00
    
Have you checked with the network guy(s) to see if the necessary ports might be blocked? Also, even your security software might be interfering, because you're see as initially coming from outside, despite the VPN. –  Debra Oct 27 '13 at 1:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.