Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a whole host of problems with an external hard drive that was working just fine a couple of hours ago. I've had this problem before once, and that was about 3 months ago, here's what I documented:

So a couple of hours ago I turned off all my computers and shut off the power to all my devices in my room, then went and turned the power off at the main switch so I could change an outlet.

A couple hours later, after I've already slowly turned everything back on, I go to my xbox to try and watch a movie and it can't seem to list any of the movies I've got. So I go to my desktop to find that my external hard drive isn't there.. even though it's on and connected. It's also stationary and hidden behind something so there's not a whole lot of tampering/physical wear to that external.

I plug it into my laptop to try and see what's going on. It starts making this endless loud screeching noise. None of that clicking that's usually associated with hd damage. It's not listed in my computers, and it shows up in Disk Management as "uninitialized" asking me to choose between two different partition types. After carefully disconnecting it and connecting it back, it asks me to format it, which I cancel.

I start googling about my issue, starting to accept the situation, torn as hell and helpless and just about ready to toss the thing.

Suddenly the screeching stops, after almost 45 minutes of it going, and Disk Management lists the drive as "Online" and "Healthy". Explorer pops up with all my files! I'm still being really careful with it and weary and treating it as though it's in fragile shape.

I've downloaded some S.M.A.R.T. software to read the values and everything is listed as "OK" . No reallocated sectors, no read errors, no seek errors. I also ran a quick self-test, which completed without error. Everything seems fine.

It looks to be a perfectly healthy external hard drive.

So what the hell was that about? Was it doing some sort of maintenance or self-test? How am I supposed to tell the difference? I would've undoubtedly killed the drive for sure if had it gone on a bit longer.

I've got the same problem now, with one exception: it doesn't magically reappear after the screeching stops. Occasionally I manage to get some S.M.A.R.T. diagnostics information, which basically reads everything as fine. The only problem is that my HD isn't initializing (so I can't access anything in it). I'm able to successfully run a quick smart test but not an extended one (I've only tried it once but got conflicting indications as to whether it was actually making any progress or not (was stuck on Random read test).

So, final question (if all else fails): Could the hard drive enclosure be failing rather than the HDD? Is this a likely possibility at all? How would I know?

[edit]

So after lots and lots of attempts at trying to get my data, trying many combinations of different computers, turning off the host before disconnecting HD, disconnecting HD and then disconnecting the power, and vice versa etc etc I finally got my drive to "initialize". Again.. just as last time, my files are all still here, I've verified that they're all complete using MD5 checksums (ExactFile). The drive is still alive and healthy according to disk management and S.M.A.R.T. Just to document again, I did many things before my drive came alive again (nothing significant) but here are the last few: I carefully removed the hard drive out of the enclosure (which was a bit dusty), and connected a spare laptop HD to the enclosure to verify that it wasn't the enclosure (I didn't want to buy a new enclosure for nothing), everything loaded up normally. It wasn't the enclosure.

I figured since I'd pretty much lost my data, I could screw around a bit anyway without worrying about recovery, and I decided to connect the external directly to my laptop (SATA) and boot up live Ubuntu. Ubuntu couldn't find my HD, and I don't think it even turned on, maybe because it required more power than my laptop provided. I just disconnected it and put back my laptop's hard drive and tried using the enclosure again with my external. Same problem with a slight difference: No hard drive size, just uninitialized. The external wasn't screeching during this time, just the silent idle sound. So I disconnected it (just USB), and the blue light on the enclosure turned off, but then the HD started to screech again. A few seconds after it started screeching, I connect the USB back in. After a few seconds of weird HD sounds (maybe 30 seconds), explorer pops up with all my files. To verify that they were back permanently, I "safely remove"d the external and disconnected the USB, waited til it turned off and then reconnected it, the files popped up again. I still hear lots of screeching, and it's constant. But it doesn't sound like the disk is being scratched, so I think it might have something to do with the spindle. Either way I'm going to back up my data asap.

share|improve this question

2 Answers 2

Yes. The enclosure's adapter chip can fail. Mostly from overheating.

For example: I have a J-Micron based USB enclosure that repeatedly powers on the drives and resets. I'm mostly to blame as I removed the fans. But the drives themselves are fine, they could handle the heat better than the J-Micron USB-SATA RAID/JBOD controller.

share|improve this answer
    
That's good to hear, means that there [just] might be a chance of recovery with a different enclosure. I don't have a desktop that I can hook this up to so I'll have to continue using USB. –  x0a Oct 28 '13 at 4:06

By what you describe, it sounds like physical damage to the hard disks. Screeching is never good. An enclosure doesn't directly control the disk, so it shouldn't cause any screeching by sending the wrong commands or anything, that's more likely to be a mechanical failure.

If you were lucky enough to get the drive back online after that, you should have immediately tried to copy any important data (maybe using a tool such as clonezilla).

Even if previously the hard disk appeared to have recovered, this may not have been the case, as the directory entries are stored in a different place on the disk than the actual files themselves.

share|improve this answer
    
Thanks for the answer! Shouldn't S.M.A.R.T. reflect these drive troubles with read-errors, reallocated sectors, etc.? i.imgur.com/wrdaGTl.png It's probably the only reason why I'm still on the fence about this. –  x0a Oct 28 '13 at 2:31
    
S.M.A.R.T isn't a very reliable indicator [link] (static.googleusercontent.com/external_content/untrusted_dlcp/…). The important line is "Out of all failed drives, over 56% of them have no count in any of the four strong SMART signals..." Often you may have no errors reported. If you really want to make sure it's not the enclosure, take it out, and connect it directly to a motherboard. But before doing any experiments I would try to copy the data off. –  Loopo Oct 28 '13 at 16:35
    
I got it to work again thankfully, I'm working on moving everything off. I think the problem might be the HD spindle, which might not letting it get up to speed. –  x0a Oct 31 '13 at 19:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.