Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm recording with SoX, and I want to make it not show output at all. When recording, it shows this output:

Input File     : 'default' (waveaudio)
Channels       : 2
Sample Rate    : 48000
Precision      : 16-bit
Sample Encoding: 16-bit Signed Integer PCM

In:0.00% 00:00:00.68 [00:00:00.00] Out:28.7k [      |      ]        Clip:0

I tried setting verbosity to 0, but it has no effect. (I'm guessing it's meant for messages other than this.)

I don't just want to hide the output, which I could do easily; I want SoX to not generate it in the first place, for performance on a weak computer.

share|improve this question

1 Answer 1

You are looking for the -q option:

-q, --no-show-progress
     Run in quiet mode when SoX wouldn't otherwise do so. This is the opposite of the -S option.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.