Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm setting up my dad's new Windows 8 PC. At some point after using the Easy Transfer utility to transfer his files from XP and installing Norton Internet Security - I don't know if those are related, they are just variables that I know about, IE10 no longer searches from the address bar - it treats everything like an actual address, so typing "cute kittens" results in it actually trying to go to http colon slash slash cute%20kittens (SU doesn't like me actually putting in a link to such a non-existent site). It doesn't even show the list of search providers when you start typing.

The only information I can find on the internet seems to indicate that this is controlled by group policy and should be fixed in the registry under hkcu/software/policies/Microsoft/internet explorer, but I don't have that key in the registry, and there's not group policy really involved anyway.

I don't see a simple "search from address bar" or similar setting in IE10 settings, but maybe I'm just missing something simple like that.

I have Norton Internet Security installed, and it's attendant browser add-ons, but I disabled those and searching still wasn't working after restarting IE10. I also have ClassicShell installed, and disabled all the IVOSoft add-ons listed, still no luck.

share|improve this question
1  
Do you have a default search provider set in IE's options? Does it work if you prefix it with a ? - like ? cute kittens? –  Ƭᴇcʜιᴇ007 Oct 27 '13 at 23:18
    
@techie007, it didn't, but I tangented off your comment into an answer. Thanks! –  Sam Skuce Oct 27 '13 at 23:52

2 Answers 2

I also faced similar issue. The search provider bar and icons won't appear under the dropdown in address bar. Also using ? or Ctrl + E won't search.

I was able to get back the search in address bar by enabling the Search in the address bar setting under Tools > Manage add-ons > Search Providers.

OS: Win 7
Browser: IE10

enter image description here

share|improve this answer
up vote 2 down vote accepted

I had to reset Internet Explorer Settings. Based on @techie007's comment, I realized there wasn't even a place to enter search providers - there was no magnifying class icon, no list of search engines at the bottom when you start typing, and therefore no "add" button to add them. After resetting IE under Internet Options->Advanced->Reset button, I was able to add search providers again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.