Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My main user profile is having problems showing stats for my network.

The Vista network connection icon has a red x in it and states, “Connection status: Unknown" "Access is denied.” on mouse hover, and the Network and Sharing center shows the following.

Network and Sharing Center Error

The main profile is local admin and other user profiles work. I have tried resetting permissions on my profile folder.

share|improve this question

migrated from serverfault.com Nov 6 '09 at 7:41

This question came from our site for professional system and network administrators.

    
Verify that your NIC is functioning correctly. Have you tried an updated driver? Are there any errors in your event logs? –  Kara Marfia May 13 '09 at 15:07
    
The computer is functioning 100% all other user profiles are fine. This user profile is working and does have access to the network. The only thing is the red X on the network tray icon and that I can’t change any settings. I found this KB support.microsoft.com/kb/945925 is doesn’t look good. –  BenM May 13 '09 at 22:52
    
This has been tagged techsupport. serverfault isn't for general troubleshooting of personal workstations –  Matt Simmons Jun 2 '09 at 3:10

3 Answers 3

  • Right click Computer and hit Manage
  • Under System Tools, double click Local Users and Groups then click Groups
  • Right click Administrators
  • Click Add to group then click Add then Advanced
  • Click Find Now
  • Double click on Local Service then click OK
  • NT Authority\Local Service should show up in the list, click OK then Reboot
share|improve this answer
    
Do you know why Local Service needs to be in this group? Something driver specific? –  Ciaran Aug 19 '11 at 15:22

I was having this problem with some accounts after re-installing 64-bit Vista. One account with the problem was "Greg". After trying several solutions from the web, I decided to get creative. So I logged into the Administrator account, created a new account named "GregNew", then went to windows explorer and copied all files under Users\Greg to Users\GregNew. Told it to replace all. Then went back into manage accounts as Administrator and deleted the "Greg" account. All is well now (for now).

share|improve this answer

Looks like a permissions issue. You can try this:

  1. Go to the administrator command prompt by clicking Start

  2. In the search box type "cmd" (don't hit enter yet)

  3. Press CTRL + Shift + Enter (accept the UAC prompt)

  4. At the C:\Windows\system32> prompt type:

    net localgroup Administrators "Local Service" /add (use quotes is object contains spaces)
    
  5. Hit Enter

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.