Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I boot Fedora 19, the GUI does not start. I can start it manually, with startx, but this does not unlock my keyring, which is annoying.

This problem started when I tried to move from GNOME to KDE and tried to install KDE and uninstall GNOME, which did not work.

I guess I would like to reinstall GNOME from scratch if I could do so without loss of data.

share|improve this question
    
What are you currently using, kdm, gdm, lightdm...? – MariusMatutiae Oct 28 '13 at 6:01
    
I am using GDM right now – Demetri Oct 28 '13 at 14:47
1  
what does runlevel return? What about grep initdefault /etc/inittab In most Linuxes, you start gdm at runlevel 5. Not sure if latter Fedoras change this convention. – Rich Homolka Oct 28 '13 at 15:29
up vote 2 down vote accepted

Fedora uses, like Arch, the new systemd, so you should be able to start gdm at boot like this:

 sudo systemctl enable gdm

I hope this solves your problem, in light of your vicissitudes.

share|improve this answer
2  
+1 .... mostly for (properly) using vicissitudes – Rich Homolka Oct 28 '13 at 15:26
    
That fails with "no such file or directory" – Demetri Oct 28 '13 at 18:26
    
Now it actually fixes the problem. Thanks! – Demetri Oct 31 '13 at 6:51
sudo systemctl enable gdm.service

and maybe

sudo yum install "@Gnome Desktop"  
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .