Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My brand new Dell XPS system has been running flawlessly except its abysmal download speeds. I have tried isolating every variable I could possibly think of but I can't figure out the problem. I've talked to Dell and Belkin without making progress (thought I'd try). Here are the speeds:

0.32Mb/s download 0.14Mb/s upload

Note that most of the time, upload speeds are actually much faster than download speeds (around 4.0 Mb/s which is better than most other devices on the network)

It's not the ISP. The slowdown happens even when transferring files inside the network. Plus every other wireless device gets approximately this:

7.21 Mb/s download 2.40 Mb/s upload

It's not the wireless router. It's a Lynksis WRT160N v1 with the latest firmware (1.02.2). Plus everything else connected to it has normal speeds.

It's not the browser. Speeds are the same in IE, FF, and when transferring files with Windows between computers.

It's not the wireless adapter. I've tried a Belkin N Wireless USB Adapter (which works fine on another computer) and a Dell Wireless Draft 802.11n WLAN Mini-Card. They have the same slow speeds when connected to the problem computer.

It's not the adapter connection. One adapter used USB and the other is a Mini-Card.

It's not antenna placement. With the same antenna position and the same device, I get different speeds when connected to the problem computer vs a good computer. Plus everything reports the connection speed as at least 11Mbps and good signal strength.

I've tried disabling IPv6 since it sometimes causes weird problems.

I've tried disabling Windows Firewall/anti-virus.

I've ensured the computer has updated drivers for both adapters.

I've ensured that Windows is up to date and so is the BIOS.

For the USB adapter I ensured that that USB port functioned at normal speeds with other USB devices.

What else could it possibly be? I finally received my copy of Windows 7 and will be trying that. I'd rather not install Windows 7 because of a particular program that will stop working so a solution besides that is welcome.

Specs:
Vista x64
Core i7 920
6GB RAM
500GB HD
GTX 260

share|improve this question
1  
Is it possible to try a wired connection to your router, just to see if that works properly? –  sblair Nov 6 '09 at 9:17
    
+1 for sblairs suggestion –  scuzzy-delta Nov 6 '09 at 9:23
    
I just have to track down a really long cable. Or lug the whole thing out to the router I suppose –  colithium Nov 8 '09 at 0:56

4 Answers 4

Does your card come with anything for measuring the quality of the connection? What are you connecting through? Walls, or nothing much at all?

share|improve this answer
    
It reports everything is fine. Plus the same adapter in the exact same physical position behaves fine when plugged into a different computer –  colithium Nov 8 '09 at 0:56

Do you still have this problem? If yes, you should try transfering data for a speedtest inside your network.

You also wrote that you will try Windows seven - Does it work better with it?

If you see 11MBits as connection-speed then this can mean your connection has a really bad signal.


BasisBit

share|improve this answer
    
7 (although great) didn't help with my problem. –  colithium Jan 11 '10 at 11:51
    
this is not really a answer to my questions... please answer them if you want me to help you. –  BasisBit Jan 14 '10 at 3:57
up vote 0 down vote accepted

I finally ran an Ethernet cord and achieved the speeds I expected. I also spent a lot of time staring intently at signal to noise graphs. Somehow (I have no idea how), the same antenna in the same location experiences radically different levels of interference depending on which machine it was plugged into.

Picture a USB antenna sitting on a desk and all you do is move the connection end one foot from one machine to the next. That was somehow the cause of it. Go figure.

share|improve this answer
    
Wireless signal capture is a dark art. –  Ryan Thompson Mar 19 '10 at 19:19

What channel is your router broadcasting on? Many come with 6 as the default, which is the most interfered with channel. Try logging into the router and setting it to channel 1,3, 8 or 11.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.