Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have to type the "set path" command manually every time in the cmd. I have it on my environment variables on my computer but it doesnt work. I even tried installing and uninstalling the java but no use. I have this set path property on User variables as well as system variables but its not working.

My main problem is that i am trying to work out the java rmi programs which requires both system32 path and java/jdk/bin path but as i said, i can have only one path at a time.

How can i fix it permanently so that i dont have to set path again and again in my cmd??

share|improve this question

migrated from stackoverflow.com Oct 28 '13 at 7:59

This question came from our site for professional and enthusiast programmers.

    
Your question is not very clear and is subject for interpretation, please tell us what is not working and how do you do to make it "work" and what errors do you get. –  A4L Oct 27 '13 at 14:23
    
Reboot the computer and check again –  NitroNbg Oct 27 '13 at 14:25
add comment

3 Answers 3

User variables get purged on reboot.

Add them to the 'Path' variable for System variables then restart cmd.exe

share|improve this answer
add comment

Depending on your Windows version you can use the SETX command.

See SETX doesn't append any path to system path variable

share|improve this answer
add comment
  1. Go to Control Panel\All Control Panel Items\System
  2. Click on Advanced System Settings on a left bar
  3. Click on Environment variables
  4. Edit for you.

In images; enter image description here enter image description here enter image description here enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.