Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Physical machine: Mac Mini running OSX 10.7.5
Virtual machine: Linux Mint 15 Cinnamon 64-bit
Using VirtualBox.

I am trying to make the linux connect to the internet. For some reason I can access the host computer with 192.168.2.100. Its set up to show me a web-page that says "It works". This I can see from the linux. But I cannot reach anything on the internet. Either FireFox says "Unable to connect" or when I run nslookup google.com I get connection timed out; no servers could be reached.

My setting on VirtualBox under the Network tab are:

  • Bridge Adapter
  • vnic0
  • promiscouos Mode:Allow All`.
  • If it makes a difference, the host has a WiFi connection to the home router.

What have I missed?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

If you just want to connect to the Internet from within the VM, just use NAT rather than a bridge.

For more VirtualBox networking info, see www.virtualbox.org/manual/ch06.html

share|improve this answer
    
Thanks, for those with the same problem: NAT works, and also Bridge with WiFi (Airport). The second one works probably because the real connection is through a WiFi connection. –  Kahil Oct 30 '13 at 7:45

Or just open the virtual machine, go to Devices → Network, then click Connect network adapter.

If it seems already connected, click again to re-enable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.