Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my eeepc 1000HA to Karmic Koala (9.10) and now I can't use the desktop. It boots fine and lets me login fine. It even uses the pretty new GUI to do all that.

But when I get to the desktop, I just see the wallpaper. Nothing else. No menu bar at the top of the screen. Nothing at the bottom of the screen. I can't launch any apps, or even shut the system down without hitting the power button. If I right click on the desktop, I can create a folder and thus gain access to the file system. But apart from that, the system is more or less useless.

I thought I could edit the xorg.conf file, but there is none.

I'm a linux newbie and completely stuck.

I've googled this without success and I've tried the Ubuntu forums without any help either.

Can anyone here help me get control of my computer again?

share|improve this question
2  
There is a "osoverflow" and is called SuperUser... they'll migrate your question there in no time :) –  Palantir Nov 6 '09 at 9:31
    
But, just like Stack Overflow, Super User is not a forum... If that sounds odd, then be sure to read the FAQs. (The FAQ does in fact mention more sites.) Also please associate your accounts at stackoverflow.com/users/51882?tab=accounts Thanks. –  Arjan Nov 6 '09 at 9:42
1  
This is a dupe of that question here: superuser.com/questions/61508/karmic-erased-my-desktop –  innaM Nov 6 '09 at 11:17
    
I'd think editing or creating an xorg.conf is not needed as you do see the wallpaper. But given Sniek's answer I might be wrong; superuser.com/questions/66646/… –  Arjan Nov 6 '09 at 12:12
add comment

migrated from stackoverflow.com Nov 6 '09 at 9:34

This question came from our site for professional and enthusiast programmers.

3 Answers

up vote 6 down vote accepted

Try this (it will reset gnome's and most gnome app's settings):

  1. start your machine (but do not log in)
  2. Ctrl+Alt+F1
  3. login
  4. mv .gconf .gconf.corrupted
  5. mv .gconfd .gconfd.corrupted
  6. Ctrl-Alt-F7
  7. login
  8. hope that it got fixed

NEVER use a command given to you before knowing exactly what it does.

share|improve this answer
1  
This worked perfectly. Thank you. Very happy now :) –  nedlud Nov 7 '09 at 5:34
add comment

Press Alt+F2 and type gnome-panel.

You should see the panel appearing on your desktop.

share|improve this answer
    
I had this happen to me when I upgraded to .. err ... I think 8.10. Alt-F2 doesn't work in this case. –  innaM Nov 6 '09 at 11:16
    
try running this command from a terminal instead? –  Mahmoud Hossam Nov 6 '09 at 15:32
add comment

Weird solution, but I had the same and it seemed that my resolution was set way to high. So I managed to reset the resolution by guessing where the menu was on the top left. ;)

You can also go to terminal and reconfiguge xwindows to use a different resolution. This was on an older TFT panel I use in my serverroom...

share|improve this answer
    
So then actually you were seeing part of the wallpaper? Nice debugging! :-) –  Arjan Nov 6 '09 at 12:08
    
Yeah, somehow it centered... The monitor (1024x768) was very old and dit not auto setup as the new ones do.... :) –  Aaaaaaaaaha ERLEBNIS Nov 9 '09 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.