Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Im trying to install Vista business. At the screen where you select what drive/partition you would like to install vista to, I keep getting "Windows is unable to find a system volume that meets its criteria for installation." I formatted two different disks, and created (with the vista install dvd) brand new partitions and neither one will work. I followed the instructions in the support article to clean the partition and ensure that it is active... no go.

The best part, this is just a reinstall. I had vista running on this HD earlier today. I know I didn't need to install any special drivers last time. Are both of my drives bad (diskpart.exe says they are both healthy)? Is there anything else I can try?

Note: Previously I had vista installed on a smaller partition on the same drive, now I'm trying to install it on one large partition.

share|improve this question
    
Is it an upgrade edition of Vista? –  Chris Thompson Jul 17 '09 at 5:33
    
Nope its a full install, Vista Business 64bit. –  Kells Jul 17 '09 at 14:21

6 Answers 6

A quick Google Search for that error message turns up these plausible options.. http://support.microsoft.com/default.aspx/kb/927520

http://support.microsoft.com/kb/938984

If they don't help try this

http://www.bing.com/search?q=Windows+is+unable+to+find+a+system+volume+that+meets+its+criteria+for+installation&src=IE-SearchBox&Form=IE8SRC

It's probably also worth checking that the drive you're trying to install on is the Master drive if it's IDE (rather than the slave drive) you could try plugging the drive into a different port too and maybe try swapping cables you might have a bad connection somewhere

share|improve this answer

I found that in my situation I was installing SBS 2008 Standard from a USB pen. Had to install it from DVD instead to stop the above error from appearing. I assume the BIOS was making the USB pen appear as a HD to the SBS installer (actually vista) and this was making it cough.

Spent days on this trying all sorts.

Hope it helps someone!

share|improve this answer
up vote 0 down vote accepted

Turns out removing an unrelated third drive made everything install smoothly. After the install completed I added the third drive back in and I was good to go.

share|improve this answer

As Chris Thompson indicated, you need to make sure it is not an upgrade edition, but a full install version?

Upgrade:

enter image description here

Regular:

enter image description here

Also, have you tried completely erasing the hard drive first, then formatting and partitioning it to how Vista likes it?

share|improve this answer

Had Linux installed already on 2 machines and I couldn't figure out why I was getting the same error message. Realized Windows needs to be boss:

http://www.geeksdo.com/set-active-partition.html

Use the Diskpart utility and set it to the target partition for Windows as the active partition. After installing Windows I'll need to do some work to get back into Linux but I'll cross that bridge later.

share|improve this answer

Erase completely all Disk partitions till you get unallocated space only left, then open Advanced options. Create a new partition from scratch and only one. Give format to it. Presto!!

Probably native or recertified Disk partitions are not compatible with win vista. Thats it!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.