Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When ever I use Google products in Firefox the page is in Thai. I am in Thailand, but I don't get this problem when using Chrome.

If I manage to find the language selector to change to English, its soon goes back into Thai.

I have checked the settings in my Google account and they are English, I have tried clearing my cookies and cache but the problem still persists.

Any suggestions to correct this?

share|improve this question

Two settings you could check are:

  1. In Firefox; Tools (Alt + T) > Options > Content > Choose, English (en) or a preferred variant should be on top (the corresponding setting in Firefox about:config is intl.accept_languages).
  2. General.useragent.locale in about:config should have the preferred language code (the one chosen in the previous step would suffice e.g. en-US).
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .