Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using a brand new Surface Pro (first generation) out of the box, installed current updates, then 8.1, and any further recommended updates after 8.1 was installed.

I've installed a two other things that don't seem connected to the issue: the Cisco Anywhere VPN client and Visual Studio 2013.

I'd like to enable Bitlocker, but during the verification step, the following error is displayed, with no options to continue:

This PC deosn't support entering a BitLocker recovery password during startup. Ask your administrator to configure Windows Recovery Environment so that you can use BitLocker.

The "administrator" in this case is me, and I don't:

  1. ... understand why this has happened
  2. ... know how to fix the issue, as if it's really necessary to make this change, what would I do?
share|improve this question

2 Answers 2

As already stated the Windows 8.1 upgrade wipes out the WinRE environment from the recovery partition. If you look in Disk Manager the partition is now empty when under Windows 8 there was content.

You can also confirm this by running

reagentc /info

This is fixed by by copying the winre.wim file from the C:\Windows\System32\Recovery folder which recreates the WinRE area in the recovery partition. Here are the steps to accomplish this:

  1. In DISKPART assign a drive letter to the recovery partition (I used Q:)
  2. Run Robocopy.exe C:\Windows\System32\Recovery\ Q:\Recovery\WindowsRE\ Winre.wim /copyall /dcopy:t
  3. Run reagentc /setreimage /path Q:\Recovery\WindowsRE
  4. Run reagentc /enable
  5. Use DISKPART to remove the drive letter previously assigned to the recovery partition.

Confirm it works with:

reagentc /info
share|improve this answer
    
I haven't had a chance to try this on my Surface -- I'll check it out. It sounds promising. –  WiredPrairie Nov 21 '13 at 19:50
    
Sorry, it didn't work for my Surface. There was an error in the enable step about the file system being the wrong format (even though I verified it was NTFS). I ended up building a recovery disk/stick, and reinstalling from scratch. –  WiredPrairie Nov 28 '13 at 12:06
    
Thanks! Worked like a charm on my Sony Vaio DUO 10 –  Alessandro Alinone yesterday

As already stated the Windows 8.1 upgrade wipes out the WinRE environment from the recovery partition. If you look in Disk Manager the partition is now empty when under Windows 8 there was content.

You can also confirm this by running

reagentc /info

This is fixed by by copying the winre.wim file from the C:\Windows\System32\Recovery folder which recreates the WinRE area in the recovery partition. Here are the steps to accomplish this:

  1. In DISKPART assign a drive letter to the recovery partition (I used Q:)
  2. Run Robocopy.exe C:\Windows\System32\Recovery\ Q:\Recovery\WindowsRE\Winre.wim /copyall /dcopy:t
  3. Run reagentc /setreimage /path Q:\Recovery\WindowsRE
  4. Run reagentc /enable
  5. Use DISKPART to remove the drive letter previously assigned to the recovery partition.

Confirm it works with:

reagentc /info

There needs to be an extra step for this method to work. After you assign the drive letter but before exiting diskpart, run:

format fs=ntfs quick override

This reformats the partition and the override allows the partition to be formatted. I had run into this same issue while deploying Windows 8.1 to Surface Pro 3 tablets. The Pro 2s that we have all worked fine but there was something funny with the new 3s.

share|improve this answer
    
This no longer works. Winre.wim is not located in the ISO or in Windows 8.1 –  Larry Feb 6 at 22:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.