Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to format a flash drive with a FAT partition to use in my car stereo, but running into a small problem. I've tried making it all one big FAT 16 partition, and the stereo won't accept it. Another flash drive I formatted in Windows works, but fdisk -l shows this:

Disk /dev/sdc: 4009 MB, 4009754624 bytes
124 heads, 62 sectors/track, 1018 cylinders, total 7831552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6f20736b

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   ?   778135908  1919645538   570754815+  72  Unknown
/dev/sdc2   ?   168689522  2104717761   968014120   65  Novell Netware 386
/dev/sdc3   ?  1869881465  3805909656   968014096   79  Unknown
/dev/sdc4   ?  2885681152  2885736650       27749+   d  Unknown

Partition table entries are not in disk order

Which to me looks like corruption, but apparently is normal for flash drives.

Trying to format this one without a partition (as in mkfs.vfat -I /dev/sdd) only shows

Disk /dev/sdd: 7876 MB, 7876902912 bytes
243 heads, 62 sectors/track, 1021 cylinders, total 15384576 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System

and still doesn't work in the stereo. So my question is how do I replicate that specific formatting in linux? Short-term (for a roadtrip this weekend) I'm okay with somehow using dd and only half the space on the new drive, but would like to know how to accurately replicate it without a working drive in the future.

Edit: did dd if=/dev/sdc of=/dev/sdd bs=4096 conv=notrunc,noerror and now fdisk -l shows both drives as being the same other than the number of bytes, but it still doesn't work, so despite the manual saying my stereo accepts 8GB sticks, maybe apparently doesn't?


share|improve this question
up vote 1 down vote accepted

Given your edit that a dd copy doesn't work, my guess is that this is a hardware incompatibility. It might not be the 8GB size that's the problem, though; it could be an electronic issue. I've heard of such electronic problems preventing some USB flash drives from working as boot devices in PCs, although they work fine as normal data disks. IIRC, the culprit in that case seemed to be something about the amperage of the device, but my memory is foggy. It might be worth simply buying a new flash drive.

share|improve this answer
I'll have to look into that, but makes sense. My stereo aside, then, do you know how to format drive to look like Windows formatted it? It seems like I've had this issue a number of times before where mkfs.vfat or mkfs.ntfs on a thumb drive didn't actually work when a windows format did. – vityav Oct 30 '13 at 23:39
There will be subtle differences between any filesystem created by Windows vs. one created by Linux's mkdosfs. I don't know of any way to force mkdosfs to create a filesystem that looks exactly like one created by the Windows tools. Perhaps you could run the Windows FORMAT utility under WINE, but I've never tried that, so I'm far from certain that it would work. – Rod Smith Oct 30 '13 at 23:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .