Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to add a custom option to the context menu in windows 7 and I've made the appropriate modification needed in the registry and the option appears in the context menu the way I wanted but when I try to run it windows gives me the following error message:

Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.

the command I'm trying to run:

@="c:\Windows\SysWOW64\ForceBindIP.exe 192.168.1.100 \"%l\""

Can someone tell me what am I doing wrong? Thanks.

share|improve this question
    
Is there really nobody who has an answer to this question? I have the same problem, with a program under "c:\program files\...". If I move it to a different folder, it works. I assume that it's a security/privilege issue. – user184411 Jan 25 '14 at 3:40

You can try replacing the absolute path to the Windows folder with an environment variable such as %SYSTEMROOT%:

@="%SYSTEMROOT%\SysWOW64\ForceBindIP.exe 192.168.1.100 \"%l\""

If that still doesn't work, try replacing the default value's type in the key you want to create from REG_SZ to REG_EXPAND_SZ. You must do this from the command line or in a .reg file since it's not possible to do it on the regedit GUI. If you wanna use CMD:

reg.exe add <key_path> /ve /t REG_EXPAND_SZ /d "%SYSTEMROOT%\SysWOW64\ForceBindIP.exe 192.168.1.100 \"%l\""

Also try removing the \" 's

I had to deal with the same issue and I finally managed to make it work. This is what it looks like in the registry editor (click for larger image):

My solution

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .