Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

PG&E (the local electricity company) came and took out the old power meters and put in a new ones by brute force and with no advance notice in our neighborhood, so my computer went down in power.

So I went to Windows 7's drive C and schedule a Disk Cleanup (chkdsk) on the next boot up.

When it boots up, it says

A disk check has been scheduled
To skip disk checking, press any key within __ second(s).

and then after it shows

To skip disk checking, press any key within 1 second(s).

it just sits there, with no further message. the hard disc light blinks every 5 seconds. So what is to be done now? I certainly don't want to brute force power off again.

share|improve this question
    
What happens if you press a key immediately when the message appears? –  harrymc Nov 6 '09 at 15:34
add comment

5 Answers

up vote 1 down vote accepted

You will have to run the chkdsk via a different method to overcome the issue you are experiencing at this time.

You need to boot up with your Windows CD and select repair to access the Recovery Console.
Then you can run "chkdsk /r" from the prompt.

For more details about the Recovery Console see Improved Recovery Options in Windows 7.

share|improve this answer
    
Good suggestion, but didn't resolve the issue for me. –  Zxaos Jan 16 '10 at 8:32
add comment

I actually had this same issue, and it was not resolved by running a chkdsk through the recovery console - that check ran fine, but the same problem presented upon reboot.

However, I was able to resolve the issue - try removing all peripherals except for your keyboard from your machine and rebooting. Unplugging my second keyboard, mouse, and usb sound card solved the issue for me - chkdsk ran normally after boot and the disk was subsequently flagged as clean.

share|improve this answer
add comment

Microsoft has confirmed this to be a bug in Win7. When some files are moved, the 'tmp' version overwirtes part of the file which results in a corrupt error flag being set. The file is intact, i.e. no error, but chkdsk is scheduled to run at next boot.

share|improve this answer
add comment

I'm too new to upvote this, but Zxaos is right, unplugging your peripherals solved it for me. I unplugged my main keyboard, and it was fine.

share|improve this answer
add comment

My laptop is experiencing this problem. There are no additional peripherals plugged in. I believe the constant hdd activity gives me about a 45 min. battery life...I just got the laptop.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.