Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was getting below error while typing showmount -e 192.168.56.2 in client machine

[root@client ~]# showmount -e 192.168.56.2
clnt_create: RPC: Port mapper failure - Unable to receive: errno 113 (No route to host)

This is my nfs server cinfiguration

nfs server ip 192.168.56.2

This is my nfs share

[root@www ~]# cat /etc/exports 
/files  192.168.56.7(rw,sync)

These are the two services running in server machine

[root@www ~]# service rpcbind status
rpcbind (pid  2626) is running...
[root@www ~]# service nfs status
rpc.svcgssd is stopped
rpc.mountd (pid 2716) is running...
nfsd (pid 2781 2780 2779 2778 2777 2776 2775 2774) is running...
rpc.rquotad (pid 2712) is running...

This is my iptables rule

[root@www ~]# cat /etc/sysconfig/iptables
# Generated by iptables-save v1.4.7 on Thu Oct 31 02:08:16 2013
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [5:388]
-A INPUT -p tcp -m tcp --dport 111 -j ACCEPT 
-A INPUT -p tcp -m tcp --dport 2049 -j ACCEPT 
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT 
-A INPUT -p icmp -j ACCEPT 
-A INPUT -i lo -j ACCEPT 
-A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT 
-A INPUT -j REJECT --reject-with icmp-host-prohibited 
-A FORWARD -j REJECT --reject-with icmp-host-prohibited 
COMMIT
# Completed on Thu Oct 31 02:08:16 2013

If I flush the iptales rule in server machine then my client is able to see nfs share

[root@client ~]# showmount -e 192.168.56.2
Export list for 192.168.56.2:
/files 192.168.56.7

That means problem with iptables rule , can anybody tell me what is the problem with my iptables rule , am I missing any other port ? How to troubleshoot these types of problems ?

I tried this method from my client machine to verify port is listening or not and this is the output of that

[root@client ~]# telnet 192.168.56.2 111
Trying 192.168.56.2...
Connected to 192.168.56.2.
Escape character is '^]'.
[root@client ~]# telnet 192.168.56.2 2049
Trying 192.168.56.2...
Connected to 192.168.56.2.
Escape character is '^]'.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The list of open ports for NFS is too restrictive. First, you will have to open the same ports to UDP, then you will need to add 2 more ports. The complete list of ports to be opened is:

 sunrpc     111/tcp    rpcbind  #SUN Remote Procedure Call
 sunrpc     111/udp    rpcbind  #SUN Remote Procedure Call
 nfsd-status    1110/tcp   #Cluster status info
 nfsd-keepalive 1110/udp   #Client status info
 nfsd       2049/tcp   nfs      # NFS server daemon
 nfsd       2049/udp   nfs      # NFS server daemon
 lockd      4045/udp   # NFS lock daemon/manager
 lockd      4045/tcp
share|improve this answer
    
Before adding 2 ports is there any changes I have to make in this file /etc/sysconfig/nfs ? –  max Oct 31 '13 at 7:34
    
Not unless you have a non-standard installation. –  MariusMatutiae Oct 31 '13 at 7:36
    
According to your answer I changed the iptables rule but 1110 and 4045 ports are still not listening from my client, so I deleted those 2 ports from iptables and added only this 111/tcp, 111/udp, 2049/tcp, 2049/udp and it starts working. –  max Oct 31 '13 at 8:09
    
Your answer is correct but I need some info like by seeing that error how can I guess that its because if port problem ? any log message will provide that info ? or tell me any trouble shooting method. –  max Oct 31 '13 at 8:15
    
Pls accept my answer if it now works. As for troubeshooting: you have connection, you have credentials (you can log in with no firewall), but you cannot connect with firewall. Hence firewall too restrictive. Looked up what I did on another pc. Otherwise, I could have googled needed ports, something like "NFS iptables ports". –  MariusMatutiae Oct 31 '13 at 8:19
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.