Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Karmic. I had no keyboard, so I enabled autologin and some other stuff over ssh to get x2x going. Now I can't find what I did. I'm trying to just start X and XBMC now. I don't need gnome. I disabled gdm:

sudo update-rc.d -f gdm remove

but it still somehow manages to start on boot. Where can I look around for what I did?

If I stop gdm then startx again, it goes straight to XBMC like I want.

share|improve this question
    
Is gdm still in /etc/init.d/? –  tj111 Nov 6 '09 at 19:02
    
Yes. I thought it's just a script for moving it into the different runlevels? –  tladuke Nov 6 '09 at 19:11

1 Answer 1

The Karmic build has mangled the init.d scripts. You should be able to stop gdm from running by modifying /etc/init/gdm.conf and adding 'runlevel [3] and' and changing the stop runlevel from 016 to 0216 like so:

description     "GNOME Display Manager"
author          "William Jon McCann <mccann@jhu.edu>"

start on (runlevel [3]
      and filesystem
      and started hal
      and tty-device-added KERNEL=tty7
      and (graphics-device-added or stopped udevtrigger))
stop on runlevel [0216]

Advice taken from this thread.

Another option to boot without gdm is to create a new entry in grub. This has the advantage of letting you boot into gdm again later if you want to. Try copying the first entry from /boot/grub/grub.cfg and putting it into /etc/grub.d/40_custom. Then add the magic word: ' text' to the end of the linux line. Mine looks like this:

menuentry "Ubuntu, Linux 2.6.31-14-generic (console)" {
    recordfail=1
    if [ -n ${have_grubenv} ]; then save_env recordfail; fi
    set quiet=1
    insmod ext2
    set root=(hd0,2)
    search --no-floppy --fs-uuid --set f5a3b213-32f8-42b1-b402-62a5e2980897
    linux   /boot/vmlinuz-2.6.31-14-generic root=UUID=f5a3b213-32f8-42b1-b402-62a5e2980897 ro   quiet splash text
    initrd  /boot/initrd.img-2.6.31-14-generic
}

Then run:

sudo update-grub

You can hold down the shift key while booting to select your new menu option.

share|improve this answer
    
Gosh, just when I had read all about run how runlevels work... –  tladuke Nov 7 '09 at 3:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.