Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Firefox with Vimperator. On Mac I use Shiori to bookmark. I also use Pinboard's default add-on (on both Mac and Windows, but mainly on Windows as there's no Shiori).

When I used to bookmark, I had this behaviour[A] (before changing Vimperator options):

Example: URL: xyz.com TITLE: xyz website

  • Pinboard add-on would fetch the title as xyz website which was fine (I reckon it directly fetches TITLE form the URL).
  • But after installing and starting to use Shiori the title I was getting in its "title" field was xyz website - Vimperator exactly the same what I could see in tabs (seems it's getting what the browser is feeding it).

So, I :set titlestring= in Vimperator to remove that extra Vimperator from title.

Now, this is what I am getting [B]:

  • When I try to bookmark using Pinboard add-on the title is undefined
  • Using Shiori it results in xyz website - undefined.

I tried to change it back to original[C] :set titlestring=Mozilla Firefox (assuming this was the original, before Vimperator) but the results are still the same as [B].

How to get read of that extra - undefined or that extra - Vimperator or - Mozilla Firefox for that matter, while bookmarking pages either with Pinboard add-on or Shiori?

One workaround is, instead of no string just add a white-space while setting title in Firefox via Vimperator there but that results in - appended to titles.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.