Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a tortured install process, I have a Rosewill RNX-6300 wifi card up and running in a machine running Windows XP (32 bit, SP2) about 15 feet from my router.

It's worth mentioning that this is the same card and same OS that I was running a week ago, with no speed issues at all.

But since the reinstall, I'm maxing out at a (rare) 36mbps, with average speed closer to 11. It's agonizingly slow, especially given that a week ago this same setup was giving me 54mbps or more routinely.

Also worth mentioning: wifi is running perfectly on all other devices and computers in the house -- a laptop, two iPads, two iPhones, a Wii.

And again worth mentioning: all of the below comes from a 4:30 a.m. testing session when there were only two devices in the house on and using wifi: this machine, and my wife's iPhone. There's never been an issue with multiple devices messing up our wifi in the past.

I'm in the "know just enough to screw things up" category, though, and I worry that while trying to install the card and set it up I may have bungled the settings somehow.

Possibly too much information, but here goes: this is the router setup screen. This is not the machine in question, but what it looks like when I log into the router:

enter image description here

These are the recent router logs. The computer in question is at 192.168.0.198.

enter image description here

When I ping, I get seemingly decent results...

enter image description here

But when I try to download something, even from a robust site like Microsoft, it's crazy slow. Just downloading IrfanView to take these screenshots took five minutes for 2MB.

enter image description here

(I tried a couple of speed test sites, but they won't even load).

Here's the ipconfig for the machine in question:

enter image description here

and the settings for the card. I don't know anything about anything here. There are a ton of advanced options I'm afraid to even touch.

enter image description here enter image description here

Here's what the wireless setup on the remote machine looks like. 802.11x verification is off (unchecked, greyed out) in the Authentication tab. "Connect automatically" is on in the Connections tab.

enter image description here

Finally, just in case it's useful somehow, the connection properties screen:

enter image description here

I don't know how to verify if I'm using a or g or n, or if I've somehow bungled a setting somewhere. Taking these screenshots is about as much as I know how to do.

share|improve this question
    
Does this issue occur when plugged in? I mean, are you sure it's the wireless which is the issue? –  Dave Nov 4 '13 at 13:00

2 Answers 2

up vote 0 down vote accepted

802.11n requires either "no security" or WPA2 with AES-CCMP.

WPA1 is about TKIP encryption. WPA2 is about AES-CCMP encryption. There are ways to do AES with WPA1, or to do TKIP with WPA2, but I don't recommend them.

It looks like you've configured your client to joint your AP using WPA[1]-style authentication, but using AES-CCMP as the cipher, which is kind of a strange combination, and may be causing your 802.11n gear to be avoiding real 802.11n rates, forcing you back down to 802.11g rates.

I'd recommend you reconfigure everything to WPA2-only, AES-only. The only devices that could do WPA1/TKIP but not WPA2/AES were built before 2003 (that is, a decade ago), and there were vanishingly few of them. I really don't know why anyone keeps WPA1/TKIP enabled on their network. You're probably more likely to spot a Tasmanian tiger than you are to see a client that is capable of TKIP but not AES try to join your network in 2013.

share|improve this answer
    
I'd love to, but the network card doesn't support WPA2, just WPA and something called "WPA-PSK". I discovered this when trying to connect it to my network, and had to retrograde my router settings to accept both WPA and WPA2 connections to get the computer to connect. –  mattshepherd Nov 4 '13 at 23:31
    
@mattshepherd It does support WPA2 (specifically WPA2-PSK, also known as WPA2 Personal). It has to support WPA2 to be an 802.11n (even "draft N") card. The specs online confirm that the Rosewill RNX-N300 (which is what I think you meant to say since the "RNX-6300" doesn't seem to exist) supports WPA2. –  Spiff Nov 5 '13 at 12:23
    
...and so it does! For some weird reason, Windows Zero Configuration only gives me WPA and WPA-PSK as options. Reinstalling and using the RAUI utility to configure gave me WPA2. –  mattshepherd Nov 6 '13 at 2:08

The speed issue could be a result of both TCP/IP on your Win XP machine and the Network Adapter Settings.

Network Adapter:

1)Make sure you have the Adapter Software available (either in a CD or on your computer). 2)Go To Device manager and uninstall the Wi-Fi Network Adapter from the machine. 3)Reboot the Computer 4)After the reboot choose to install software manually and point to the Driver CD.

We do this to reset the Wi-Fi Settings to their defaults and resolve any driver based issues.

OS TCP/IP Troubleshooting:

1)Open Command Prompt (Start->Run->CMD)

2)Run the following commands:

netsh int ip reset reset.txt

ipconfig /renew


3)Now Reboot the machine once again.

This should solve your issue.

If it does not resolve the issue, please update your Wireless Network Adapter software and Device Firmware from the internet after connecting your PC with a Network Cable to the Router. Then try the speed test.

Also make sure there are not water bodies like an Aquarium, Water Storage tank, a water purifier etc., near the location of your PC or Near the Wi-Fi Router. Water effects negatively any Wi-Fi signals.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.