Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Corsair SSD won't work and I have some critical data on it that I didn't back up (I needed to create a copy of my mechanical storage device, just forgot). The drive isn't detected by the OS or BIOS. I also tried it on another system, but all that happened was the OS failed to load (my guess was that it knew the drive was there, just couldn't read it). I tried powering it on without the data cable for a bit of time to see if it'd work again, but it didn't. Any ideas of how I can get the data off of this drive without having to send it in?

share|improve this question
    
what model? I VAGUELY recall some SSDs having major firmware issues –  Journeyman Geek Nov 5 '13 at 1:51
    
It's the Corsair Force GT 120. –  user1870398 Nov 5 '13 at 1:56
    
I would seriously consider the possibility of firmware related issue like the above commenter suggested. Update your motherboards BIOS, update SATA controller/chipset in windows, and update the firmware for your particular SSD. –  jRadd Nov 5 '13 at 2:32
    
I can't flash the firmware. The drive isn't detected, so I can't use any tools on windows. –  user1870398 Nov 5 '13 at 3:15
    
the regular force 120 had issues, and that was what I was thinking of, I suspect. –  Journeyman Geek Nov 5 '13 at 3:38

2 Answers 2

If you are familiar with linux, I would boot up a linux live cd/dvd, and try to recover data, or see if it is being recognized at all.

For an excellent list of data recovery tools, check out this page on the forensicswiki

As for something a bit more simple, you can try installing Puran Utilities in Windows. I have had good luck with this tool, but it may not work in this case.

edit: If it is not detected in windows, then the next best option is to use a linux live cd/dvd, and/or that list of recovery tools mentioned above.

share|improve this answer
    
It isn't detected on Windows, that's the problem! –  user1870398 Nov 5 '13 at 2:08
    
did you try another windows computer? try linux live cd? I have had luck with usb/sata adapters.... attach the usb/sata adpater after a windows boot. –  Logman Nov 5 '13 at 23:49

if bios can still see it, get a linux live cd (PartedMagic | SystemRescue)and boot into memory and mount the volume and grab your files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.