Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I purchased the Surface Pro 2 a few days ago (release day) and it has been running great, but over the last 3 days I have encountered a weird charging issue.

I like to drain my battery down to near 8% range before I charge it, and sometimes it will go to sleep or hibernate before I get a chance to plug it in.

This issue has happened to me 3 times this far over the last 3 days.

When at 8% battery, I plug in my device.

The first two times, the battery icon would display plugged in, not charging, and the 8% would continue to drop to 0%, still saying plugged in, not charging. When it happened just now, the icon displayed plugged in, charging, but continued to drop to 0%.

The first time I figured this was just an issue where I was drawing too much current for it to be powered on, and charge at the same time.

When in this state, I accidentally removed the charger, and the device powered down, power loss, as expected, however, when the device booted back up, it showed that it was plugged in, and charging, and that my battery was at 100% (it had been on the charger for a while), as it should be... This was a genuine 100% charge, as the battery lasted its full life after being unplugged at this point.

The second and third time this happened I paid more close attention to it, and the same thing happened. If I reboot, it becomes fixed, but still, if the charger is disconnected, loss of power, device force powers down, but if I initiate a shutdown / reboot, everything is back to normal..

Has anybody else encountered this issue? Is it something with Windows8? Is it a known issue with the Surface Pro 2? Do I have a hardware issue?

share|improve this question
    
you should ask this on the official Surface support forum: answers.microsoft.com/en-us/surface/forum –  magicandre1981 Nov 5 '13 at 17:36
    
I have a similar problem since yesterday :/ –  Sam Jan 1 at 16:09
    
I have the original Surface Pro, and this happened to me, very occasionally, usually just before Microsoft issued an update. I believe the issue is firmware related, as after I received a firmware update, it never happened again. Have you checked for a firmware update? –  JoelSolo Jun 21 at 20:38
    
Can you not just Send it back and have it replaced –  Dave Jun 21 at 20:45

1 Answer 1

Same exact issue here, although not a serious fix, changing power management options, for example setting never turn off display, triggers problem. Resetting these options allows battery to charge again and give correct charge state. Till update fix this might work for you.

share|improve this answer
    
For me resetting the power options did not fix the problem :( –  Sam Jan 1 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.