Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My virtual hosts lines:

<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot /www/docs/example.com
    ServerName example.com
    ErrorLog logs/example.com-error_log
    CustomLog logs/example.com.com-access_log common
</VirtualHost>

And when I apache restart (sudo apachectl -k stop) get this error:

Warning: DocumentRoot [/www/docs/example.com] does not exist

I've checked some ways:

All files and directories permissions is OK, everything 755. I think, maybe this error about SeLinux and disable it. But not working. Still same error.

How can I fix this problem?

share|improve this question
    
The directory /www/docs/example.com definitely exists? –  pjc50 Nov 5 '13 at 11:50
    
Not exist. Created this directory by manuel but same error. –  user1213807 Nov 5 '13 at 11:56
add comment

1 Answer

You have to escape the . symbol. Try this instead:

DocumentRoot /www/docs/example\.com
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.