Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VirtualBox image of win-xp, need to let it connect to the internet. The host is Ubuntu 64bit. What are the necessary steps I should take?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If you install XP on VBox with the deafult settings (AMD/PCNet III, iirc) and then install the guest additions it should connect to internet.

alt text

Open the Sun VirtualBox console and highlight the OS in question (the virtual machine you want to edit must not be running!).

alt text

In 'Details' open the Network properties, make sure at least 1 virtual adapter is enabled (checkbox), from the 1 drop down menu, pick the adapter model (PCNet-Fast III should be default and XP should automatically install this driver) and the 2nd drop down by default says 'Attached to: NAT'.

alt text

Boot Windows XP and check if a network adapter is installed in the Device Manger

If you choose the Intel Pro 1000 series adapter, you can download the driver for your OS here.

share|improve this answer
    
I installed the guest Addition, but really have no idea how to continue from here. Where is the menu I choose from the Intel Pro 1000 for example? –  Itay Moav -Malimovka Nov 7 '09 at 5:06
    
What confused me is the image showing the machine as running. the details tabs cannot be opened when the machine is running... –  Itay Moav -Malimovka Nov 8 '09 at 1:01
    
that's right, will add this bit. –  Molly7244 Nov 8 '09 at 1:03

Under the settings for the VM, you'll have to change the network configuration.

Set it to bridged if you want it to appear as it's own node to other nodes on the network while sharing your internet connection.

Set it to NAT if you don't want it to be visible as another node, but still share the connection.

The only option that won't allow you internet access is host only.

share|improve this answer
    
How do I change it? When went to the settings, the only option I see is to add another host only adapter –  Itay Moav -Malimovka Nov 7 '09 at 5:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.