Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just enabled vsftpd on my laptop (Fedora 18 if that matters and vsftpd version 3.0.2) and tried to connect to it with my Android phone: success!

Still, some minutes later, I stumbled upon a folder with only two photos, while in Nautilus it shows quite a few extra photos and some videos.

This two photos were sent from a friend and the rest (both videos and photos) come from our DLSR camera.

After playing around I noticed that our friends' images are .jpg while the photos from the camera are .JPG. A quick bash loop and all images are .jpg: win! :)

Still, movies coming from the camera are .MOV and changing them to .mov does not help it. I tried just to change the extension to .avi and it does work (though the video is still in mov format)

So I turned into man 5 vsftpd.conf and could only find deny_file and hide_file which by default should be (None) according to man page.

Anyway I added them to /etc/vsftpd/vsftpd.conf, restart it and still no videos :S

Any idea what could be wrong?

Ok, I got a pointer, SELinux seems to be the problem, (see comments below). Still, other users will hit this too, so, any clue how to make SELinux not block some files or others?

share|improve this question
    
Are you sure it is not Android's fault? Could it be that Android does not recognize the formats you mentioned (JPG for jpg, mov or MOV,...) and thus won't diplay the files? –  MariusMatutiae Nov 5 '13 at 19:31
    
No, it's vsftpd or someone else within the laptop. The same (doing an ls) does not work on the terminal ftp client on the laptop itself. –  gforcada Nov 5 '13 at 20:24
    
Are you sure you're not (also) changing permission on the files when renaming them? Have you tried disabling SELinux in Fedora to ensure it's not blocking things? –  Ƭᴇcʜιᴇ007 Nov 5 '13 at 20:34
    
No, permissions keep the same: 644 user:user the same as the pictures that I can see. I will try disabling SELinux, thanks for the tip! –  gforcada Nov 5 '13 at 20:43
    
Thanks techie007, it was SELinux. Setting it to permissive was enough (setenforce 0 as root on a terminal). –  gforcada Nov 5 '13 at 20:49

1 Answer 1

Ok finally found it:

setsebool -P ftpd_full_access 1

The -P switch makes it permanent.

For some reason SELinux only allows a limited access to ftp functionality, the command above tells SELinux to allow full access to ftp, whatever that means...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.