Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to follow instructions here to get emacs going but I am stuck with deleting the .emacs.d folder. What do I do when the command line asks rm: descend into directory '.emacs.d'?

a@b:~$ sudo rm -r -i .emacs.d
[sudo] password for a: 
rm: descend into directory `.emacs.d'? 

Is there a simpler way to find and delete files without using the command line? I am unable to locate this file in GUI.

share|improve this question
1  
Try adding the -f option –  Oliver Salzburg Nov 5 '13 at 23:58

2 Answers 2

up vote 2 down vote accepted

You are adding the -i option which means --interactive so it will ask you if it can delete each file and directory. Is the only reason why "descend into directory `.emacs.d'?" appears.

So you either, forget about the -i or keep pressing Y.

BTW, sudo is not necessary:

(Optional) delete the .emacs.d/.git directory. You'll probably want to create your own git repo for .emacs.d

Delete only implies:

rm -r .emacs.d/.git
share|improve this answer

It appears that .emacs.d is a folder, and the rm command is asking to confirm that you want to delete the files within the folder as well. To confirm this prompt, type y (for yes) and press enter.

Out of interest, why are you using sudo on this command? The files are in your home directory, so you do not need root privlages to delete them (unless the permissions are messed up)

share|improve this answer
    
Thanks, I tried without sudo and it all worked. Previously, it was asking if I was the root, probably that's why I was using sudo. –  Zeynel Nov 6 '13 at 0:03
    
@Zeynel exactly what you used? Also, if it worked mark it the answer as accepted. –  Braiam Nov 6 '13 at 0:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.