Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to get --color=auto as the default ls argument.

$  ls --version
ls (GNU coreutils) 8.21
…
$  echo $LS_COLORS
no=00:fi=00:di=00;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=00;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.ogg=01;35:*.mp3=01;35:*.wav=01;35:
$  echo $LS_OPTIONS
--color=auto

Unfortunately when I run ls I still get non-colored output (running ls --color=auto manually gives me colors).

How do I make --color=auto a default ls argument?

share|improve this question
    
Is ls aliased with different options? Try 'type ls' to see if it is aliased. \ls should run the unaliased ls. –  jaychris Nov 6 '13 at 5:11
    
Thanks, but all I get there is an absolute path to the ls I installed to $HOME\opt\bin\ls –  A T Nov 6 '13 at 13:46

2 Answers 2

up vote 0 down vote accepted

I think you might have thought that GREP_OPTIONS being supported implies that LS_OPTIONS would be too, as in: http://stackoverflow.com/questions/793483/unable-to-put-colors-for-ls-by-ls-options

This is not the case though, so you're best doing something like this in your bashrc or equivalent:

alias ls='ls --color=auto'
share|improve this answer
    
I heard that using alias where an environmental variable can be given instead isn't recommended… all well, it's working now –  A T Nov 8 '13 at 3:47

It isn't enough to just set $LS_OPTIONS as a bash variable; you must also export it to the environment so that child processes pick it up as well.

$ export LS_OPTIONS
share|improve this answer
    
I set the environment variables using LS_OPTIONS="--color=auto" notation in .bash_profile. I tried adding export lines there also (after your answer); but that didn't make a difference. –  A T Nov 6 '13 at 4:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.