Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm going insane.

Can someone please help me to COMPLETELY DISABLE the 'This Connection is Untrusted' page on Firefox.

Facts:

  • I am running Firefox 23.0 on an Ubuntu machine (downloaded and installed ubuntu today)
  • It is a work computer and I have to use my employer's proxy
  • While visiting Webpages/webapps like Gmail or Google brings up the 'This Connection is Untrusted' page and I have to go through the whole tedious task of selecting 'I understand the Risks' and add Exceptions, etc. etc. The fact is, I don't care about the risks. I would rather this computer melt into the ground than have to see that page ever again. I want to dance naked in untrusted pages and not give a damn about the consequences. I just never want to see that page again. Ever.
  • For some sites (eg. wikipedia), the css doesn't load and I end up seeing them in plain text. As a result these sites are completely useless. Wasted hours trying to solve this for stackoverflow.com.
  • These issues happen on the Firefox on my Windows XP machine as well (also using the same proxy).

I don't want to export/import certificates or create exceptions for every site that shows this bloody page. I just want this page gone. I don't want Firefox to tell me what's safe and what's not.

Also, my system time and date are correct. I've also tried the lies on this page too with no good results.

Edit: I've also tried the whole going into the Advance->Certificates->validation setup page and unchecked 'Use the Online Certificate Status Protocol (OCSP) to confirm the current validity of certificates' checkbox. Nothing happened even after restarting firefox or rebooting. I need help.

Thanks.

share|improve this question
    
I have not tested this, but this MAY be your answer: support.mozilla.org/en-US/questions/957485 –  Darius Nov 7 '13 at 8:16
1  
Why do you want a workaround for the symptoms? Why don't you ask your employer to fix the cause? Normally you should not see any https error pages. –  Werner Henze Nov 7 '13 at 8:22
1  
My employer encourages employees to use IE8. They are living in the 1990s and are at home watching MASH on their cathode ray tube TV. –  TheIronChef9 Nov 13 '13 at 0:01
add comment

3 Answers

It's a really dangerous thing to do, because you will not be able to detect a Man-in-the-middle attack anywhere (at home, on a public wifi...)

The solution is to add the root certificate used by your entreprise proxy as a trusted authority (CA) in your browser, as described here :

https://wiki.wmtransfer.com/projects/webmoney/wiki/Installing_root_certificate_in_Mozilla_Firefox

To obtain the proxy certificate, click on the lock icon near the URL of an HTTPS page, click "View certificate", and on the windows click on your proxy's certificate (like here) then export it and proceed as explained above to import it as trusted CA.

share|improve this answer
2  
The link provided first gives me an 'Untrusted page' error then when I add an exception it goes to a 404 page not found. –  TheIronChef9 Nov 8 '13 at 1:23
    
Thanks you, fixed that –  Eric Gillet Nov 12 '13 at 22:21
add comment

If you're just looking to disable HTTPS error pages:

Go to Tools > Options > Advanced "Tab"(?) > Encryption Tab Click the "Validation" button, and uncheck the checkbox for checking validity. Not recommended, but it should stop them from displaying.

I'd advise making sure your system time is correct, if it isn't, that could be triggering all the certificate errors.

share|improve this answer
1  
I Should have mentioned it in my post but I've already tried this approach and had no good results. I did this, restarted firefox (even rebooted since) and nothing. Its as if this checkbox does nothing. –  TheIronChef9 Nov 7 '13 at 23:26
add comment

If you install an older nVidia card (or possibly other brand) this error can happen as well.

It will automatically set your date and time back, for example, I just installed a 9600GT on a Windows 7 system and it put the time back to some time in 2008. Thus I got the certificate warnings in Firefox.
Changing the date and time back fixed it all.

share|improve this answer
3  
This really doesn't have anything to do with installing an Nvidia card. It probably has more to do with the computer being unplugged for long enough that the CMOS time is reset. –  Michael Frank May 28 at 23:02
add comment

protected by Community Jul 6 at 21:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.