Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 installed on two computers.

I can share folders between them fine.

However, I can't seem to share printers between them: when I right-click on the printer I expect to see "share printer" but there is no option for that.

alt text

When I read about "share printers" in the Windows 7 help, it talks about this computer "not being able to connect to a home network", yet they seem to be connected fine (I can share files between them).

Why can't I share printers between the computers if I can share files?

share|improve this question

5 Answers 5

up vote 3 down vote accepted

Try the Printer Properties, then check the Sharing Tab

share|improve this answer
    
Per @hanzie's answer, look at @Edward's image above. Now *don'*t click on the printer's "Properties" menu item at the end, click on its "Printer Properties" menu item in the middle. The sharing tab is in that one. Nice user experience design, Microsoft! –  Jim Ferrans Aug 29 '10 at 23:09

FOUND IT!

there are 2 properties in the right click menu. I have no clue why, but there are.

right click, go to printer properties, NOT properties. They're both listed on mine, anyway.

There's the sharing tab, right there.

share|improve this answer
    
+1: This was my version of the problem. Solutions elsewhere said to click on "Properties", adding to the confusion. Thanks! –  Jim Ferrans Aug 29 '10 at 23:03

I had Cannon MF3240 with the same problem. Right after Windows 7 x32 update and installation of Symantec Endpoint security I could not find the "SHARING TAB". After one hour circling around and messing up with the "homegroup and network sharing" options I went back to:

Start / Devices and Printers / right click on the printer / Printer Properties / Sharing (Second Tab)

... and there you go.

share|improve this answer

Have you created a HomeGroup? IIRC you can specify sharing of printers when you join the HomeGroup.

share|improve this answer

Go to Start -> Printers and devices -> Printer in question -> Customize printer -> Sharing tab -> Share this printer.

share|improve this answer

protected by studiohack May 3 '11 at 9:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.