Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problem with mounting Windows network shares from my OS X 10.7.5 - it worked but it stopped and nothing helps and nothing in logs.

Here what I get when trying to mount it manually:

mount -t smbfs //10.0.0.7/d /tmp/test

When doing sniffing with tshark - no packet it sent through and I get immediately return from the command:

mount_smbfs: server connection failed: Unknown error: -1

Nothing in /var/log/syslog.log and /var/log/kern.log.

The Finder does not work either - it throws an error that something is wrong (in czech thus I'm not sending the message here).

I just cannot connect to any network shares.

In virtual Windows 7 in Parallels Desktop I can connect successfully, but not within the network share (so the Win7 is behind OS X NAT) but only with its own IP address.

The Windows server share is on the same network segment connected through switch.

Any advice how to debug and what can be wrong? I spent hours to find solution on Google and here but no-one with this kind of problem and I do not know how to further debug it since there is no meaningful log / trace etc.

I can ping 10.0.0.7 and I can connect to FTP server on 10.0.0.7 - the Windows machine (XP) has firewall completely turned off. The problem is that with tshark, I'm not seeing any packet sending to 10.0.0.7 so it's not even trying to reach the server.

share|improve this question
    
Did you just recently update OSX? There is a change in the authentication methods enabled by default, though it doesn't exactly match your symptoms. Any security software on the Mac? –  Debra Nov 7 '13 at 14:07
    
The problem is that I do not remember if it started after some macos update but I did not upgrade macos itself. I have no security software on the mac and I checked that the firewall is empty (ipfw). The problem is that I even do not see any packet sent to 10.0.0.7 from my mack (I'm using tshark -i en1 -n 'host 10.0.0.7') - the error "unknown error: -1" rise immediately when using the command line mount. –  user2169619 Nov 7 '13 at 14:31
    
The reason I asked is that you said it works from within parallels. What if you use just smb://10.0.0.7 to "connect to server"? –  Debra Nov 7 '13 at 14:34
    
I think I'm more closer to the problem - I now tried to connect directly to the port 445 with "telnet: connect to address 10.0.0.12: Operation not permitted" which does not occurs to another ports so there is something blocking the port 445 - what it can be? I'm novice in macos firewalling. –  user2169619 Nov 7 '13 at 14:37
    
just to clarify - the windows share server is on 10.0.0.12 now –  user2169619 Nov 7 '13 at 14:38

1 Answer 1

I have finally found what was blocking it and it was cpwf.kext kernel module which comes from checkpointvpn. I'm very curious why the hell is this module doing this even I'm not connected to any VPN.

sudo launchctl unload /Library/LaunchDaemons/com.checkpoint.epc.service.plist && sudo kextunload /System/Library/Extensions/cpfw.kext

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.