Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using windows xp sp2. Whenever i ping localhost it resolves to ::1 if network cable is connected. If i remove network cable then localhost resolves to 127.0.0.1. I do not know about this strange behaviour of localhost. Google do not help me on this. I want localhost needs to resolve 127.0.0.1 without touching IPv6. My another machine has IPv6 but in that localhost always points to 127.0.0.1.

share|improve this question
1  
Just as an aside, if you are really running SP2, you need to immediately disconnect your computer from the Internet. If you are running SP3 and all additional patches, you are ok until April, 2014. –  ChrisInEdmonton Nov 7 '13 at 15:21
1  
I don't use internet on that machine. In my case I connected my system in LAN. –  kcihtrak Nov 7 '13 at 15:48
    
Sounds like you have a DNS server that is translating “localhost” to ::1, and you get 127.0.0.1 only when you fall back to your hosts file. Is your other machine on the same network? pointing to the same DNS server? –  Scott Nov 7 '13 at 16:30
    
have you disabled IPv6 in your network adapters protocol binding and configuration dialog? just uncheck the box for 'Internet Protocol v6' –  Frank Thomas Nov 7 '13 at 17:34
    
Just as an aside, if you are really running SP2, you need to immediately disconnect your computer from the Internet. If you are running SP3 and all additional patches, you are ok until April, 2014 Really‽ ⊙▃⊙ Then what happens? Do they have to disconnect in April? Can they use the Internet ever again? ఠ_ఠ (For the record, I still use XP SP1 but my system hasn’t exploded or melted yet.) –  Synetech Dec 27 '13 at 7:11
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.