Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Virtual Box Machines from a Mac Book Pro as the host OS and would like to be able to have all my files stored locally on the host OS's partition using Apache servers running from within guest OS's setup with virtual box.

I intend on using system links and altering conf files to be able to facilitate this, with the the hopes that I could do most of the coding and version controls locally on the mac and then just use the virtual machines for testing.

I run the following VM for work and am using this as my first test case for this process:

Win7 Pro, with XAMPP 1.8.2

by default the apache server is setup to use the following as document:

DocumentRoot "/xampp/htdocs"

I added the local directories to the machine by enabling shared folders in Virtual Box, so that when Win7 boots I have access to my local files on OSX.

I want to add projects from that mapped drive to my appache httpd.conf so that I can host and access them from within Win7.

I have followed this question's advice in an attempt to get this working, each method appears to add the remote directory to apache however I get errors with permissions.

For example, say that in Win7 my shared directory from OSX was:

D:\Development

Then I added a directory and alias to my httpd.conf file:

Alias /dev/ "D:\Development"
<Directory "D:\Development">
      Options Indexes FollowSymLinks MultiViews ExecCGI
      AllowOverride All
      Order allow,deny
      Allow from all
</Directory>

When I opened a web browser from within the guest OS (Win7) and go to localhost/development I would get permissions errors.

I then tried to use symlinks by creating a link to the D:\Development location within C:\xamp\htdocs by doing the following command in a cmd prompt

mklink /d dev D:\Development

This created the link and the directory was within xampp's htdocs. However when attempting to open in the web browser I still recieved permissions errors.

I attempted adding both the symlink path and the mounted path to alias' and directory for httpd.conf

I am sure that I am just misunderstanding something and this is probably a simple fix, perhaps do I have to specify the folder by a full network path or something? Is this process different because I am using Apache from a Vbox and wanting to keep my files on the host OS?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I found a way to get this to work by following the question asked here: Creating a symbolic link to mapped network drive in Windows

Without even altering the http.conf for apache in xampp I just created a symbolic link using the full UNC path and not the mapped directory, and it worked just fine.

So basically I just used

mklink /D C:\xampp\htdocs\development \\OSX\users\user\deveopment
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.