Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So for some reason all my images on my blog disappear, no idea why now, but the first time it happened I removed Varnish, and the images came back, everything worked fine. An hour later the images disappear. This time I reboot apache and change the documentroot instead of zpanel, which I removed already. I then restarted apache and the images came back.

Well again, an hour later the images disappear! The images return a 403 forbidden or just forbidden when you visit them directly.

I cleared my error log and when visiting the error log.

[Sat Nov 09 08:44:40 2013] [crit] [client 108.162.246.216] (13)Permission denied: /var/www/travisingram.net/public_html/wp-content/uploads/2013/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

Really starting to rage badly because nothing is working to fix it, and I can't find anybody else having my issue at ALL.

Help would be EXTREMELY appreciated.

My site: http://travisingram.net/

I am running CentOs 6 with latest lamp setup.

share|improve this question

Check the .htaccess file permissions:

ls -la /var/www/travisingram.net/public_html/wp-content/uploads/2013

Maybe, it doesn't have read permissions. Try:

sudo chmod 0644 /var/www/travisingram.net/public_html/wp-content/uploads/2013/.htaccess

And checkout.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .