Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run "yum install" on my server. Upon replying "y" to install all listed updates, I am getting this Transaction Check Error.

Transaction Check Error: file /etc/libvirt/libvirtd.conf from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /etc/rc.d/init.d/libvirtd from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /etc/sysconfig/libvirtd from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/bin/virt-xml-validate from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/augeas/lenses/libvirtd.aug from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/augeas/lenses/tests/test_libvirtd.aug from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/libvirt/schemas/capability.rng from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/libvirt/schemas/domain.rng from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/libvirt/schemas/network.rng from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/libvirt/schemas/nodedev.rng from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/libvirt/schemas/storagepool.rng from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/libvirt/schemas/storagevol.rng from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/af/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/am/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ar/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/as/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/be/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/bg/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/bn/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/bn_IN/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/bs/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ca/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/cs/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/cy/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/da/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/de/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/el/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/en_GB/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/es/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/et/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/eu_ES/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/fa/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/fi/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/fr/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/gl/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/gu/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/he/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/hi/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/hr/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/hu/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/hy/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/id/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/is/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/it/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ja/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ka/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/kn/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ko/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ku/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/lo/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/lt/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/lv/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/mk/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ml/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/mr/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ms/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/my/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/nb/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/nl/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/nn/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/nso/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/or/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/pa/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/pl/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/pt/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/pt_BR/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ro/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ru/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/si/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/sk/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/sl/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/sq/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/sr/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/sr@latin/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/sv/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ta/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/te/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/th/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/tr/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/uk/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/ur/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/vi/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/zh_CN/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/zh_TW/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/locale/zu/LC_MESSAGES/libvirt.mo from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/man/man1/virsh.1.gz from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64 file /usr/share/man/man1/virt-xml-validate.1.gz from install of libvirt-0.8.2-29.el5_9.1.i386 conflicts with file from package libvirt-0.6.3-33.el5.x86_64

Error Summary

I installed "yum-utils" and run "/usr/sbin/yum-complete-transaction" but it outputs that no transaction to complete.

I wonder how can I proceed?

I am on CentOS 5.9 Final

share|improve this question
    
What are you trying to install? There seem to be many conflicts between i386 packages and x86_64 packages. What's the output of uname -a? –  rickhg12hs Nov 9 '13 at 7:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.