Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 9.04. Worked fine for months, then I rebooted yesterday after weeks of continuous operation. Now audio won't play through the speakers. The USB headset works fine, but the Conexant audio (CX20549) does not. Weirdly, it thinks it's playing. pavumeter shows appropriate levels, volume looks OK in alsamixer, but no sound.

I did find this page: http://www.eugeneteplitsky.com/fixing-silent-pulseaudio-in-ubuntu-9-04/

Unfortunately the advice there doesn't help me. For one thing, the syntax for the alsa-base.conf file is apparently not actually documented anywhere. For another, my chipset isn't listed in the kernel.org docs he links to!

EDIT: would upgrading to 9.10 help? Is there a major change in the audio subsystem between 9.04 and 9.10? Any suggestions?

EDIT 2: This is stranger than I thought. Sound works normally in Xine, but is silent in Audacity, VLC and mplayer. What the?

share|improve this question
    
the link you're talking about is using modprobe-style options (like the ones found in /etc/modprobe.d/* ..). you may also look into tweaks in a .asoundrc: alsa.opensrc.org/index.php/.asoundrc –  quack quixote Nov 9 '09 at 0:30
add comment

2 Answers

up vote 1 down vote accepted

Audio using PulseAudio is very buggy by default in 9.04. It is improved in 9.10, but there are still issues.

You can try to solve it following this recommendations: http://ubuntuforums.org/showthread.php?t=843012.

Also, it is worth considering Kubuntu, which doesn't use PulseAudio by default (this is true for the latest versions of Kubuntu).

share|improve this answer
    
I ended up upgrading to 9.10 (which I would have done soon anyway) and sound is working now. I will keep your suggestions and Quack's in mind should the problem return. –  CarlF Nov 9 '09 at 1:14
add comment

Check the mixer settings.

For some reason it sometimes it goes to zero after a reboot (on some Ubuntu installations).

share|improve this answer
    
First thing I tried. Those settings are fine. –  CarlF Nov 7 '09 at 18:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.