Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Intel® Core™2 Quad Processor Q9550 installed and it is supposed to feature SSE4 and virtualisation instructions ( cpu flags vmx and sse4_1 ), but CPU-Z reports it does not:

CPU

The mainboard is a Gigabyte EP35-DS4.

Mainboard

I've tried both Windows, Linux 32-bit and 64-bit kernels and the flags are missing in all accounts.

On the other hand, another Q9550 works fine, although on another mainboard model - still Gigabyte.

What am I doing wrong here?

share|improve this question

2 Answers 2

If I was you, I would go into the BIOS and make sure that the Virtualisation bit / VT is set to enabled as it is disabled by default on some motherboards.

As for SSE4, I again would look in the BIOS, but I have never had to deal with this before and have never seen an option to have it disabled.

share|improve this answer
1  
Whether these options are available or not is determined not only by the CPU, but also by the motherboard. If these options are not visible in the BIOS, and if you have the latest version of the BIOS, then they are simply not available for your model. –  harrymc Nov 7 '09 at 18:35
    
@harrymc - I ended up flashing the MB and now it works. Mind putting your comment in an answer so I can accept it? –  Robert Munteanu Nov 7 '09 at 18:40
up vote 1 down vote accepted

Flashing the MB did make it work. Although the CPU was listed as supported and functioned properly, virtualisation was not available for it in the revision I had installed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.