Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been experiencing an issue since I've up upgraded to Windows 7 where all flash videos have horrible frame rates when run in full screen mode. I have tried multiple browsers and i have the latest version of flash and video drivers. I have tried re-installing flash and disabling hardware acceleration. The problem occurs on youtube and hulu.

This is a clean install on a Core 2 duo with 4GB RAM and an Nvidia 8400M GS.

share|improve this question
    
Are you using the debug version of the Flash player? Just something to check. –  Tmdean Nov 7 '09 at 20:03
add comment

2 Answers

Go to nvidia site and download the drivers compatible with windows 7 , don't just update them. My computer used to have the same trouble when i used full screen and then it restarted. The new drivers fixed the problem. Hope i helped a little

share|improve this answer
add comment

Okay, I think I've got this figured out. I thought it might have had something to do with Aero being on because it started working fine when I disabled it. However, I have been able to reproduce it by messing with the hardware acceleration feature.

I think the fix is indeed to disable hardware acceleration. I didn't see any change at first, but when I reloaded the page (F5, or CTRL+F5 for full reload) it started working.

The fix:

  1. Take the flash video out of full screen.
  2. Right click on the video and select 'Settings'
  3. In the 'Display' tab, un-check the 'Enable hardware acceleration' check-box.
  4. Refresh the page.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.