Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use the search field in the Firefox toolbar all the time at home and at work. But recently the search (magnifine glass) button has just stopped working. I can still press enter/return but when I click the button, nothing happens.

Does anyone have a solution for this issue? Has anyone had this problem before?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Firefox addons are usually the cause of interface bugs. Have you installed (without necessarily uninstalling) addons, specially addons that may affect this search functionality? Keep in mind that some addons modify firefox's configuration permanently, and do not revert the changes when they are disabled or uninstalled. Most of the configuration information is kept in the profile, so simply reinstalling Firefox keeping the profile probably will not help.

If you believe it could be caused by one of the addons you installed, you can try disabling it (and restart firefox), and if that doesn't solve it, you can search the web to find out if that addon/s can cause this problem.

share|improve this answer
    
Thanks. I took you advice, but before I went and started disabling random addons, I started Firefox in safe-mode. I tried the search button in this mode and it worked. I start Firefox normally and strangely the search button was working. Very odd, but it's working. –  Adam Harte Nov 9 '09 at 23:02

That's never happened to me before, and I can't find anything in about:config related to the magnifying glass and it's onclick action. Have you tried uninstalling then reinstalling Firefox?

share|improve this answer
    
same here, reinstalling may not suffice, not without uninstalling FF completely. backup the profile and favorites, e.g. with MozBackup: mozbackup.jasnapaka.com –  Molly7244 Nov 8 '09 at 3:34
    
That's what I was implying by reinstalling. Uninstall, install again. Will edit for clarity. –  John T Nov 8 '09 at 3:59
    
I was hoping I would have to do this. If I don't find something to fix it, I guess I have no other option –  Adam Harte Nov 8 '09 at 8:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.