Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The subject PC has many hard drive partitions dedicated for different purposes, C: being a Windows XP system drive and F: (which is actually the next primary partition placed right after C: physically) being intended to host a newly installed Windows 7 instance (meant for "dual boot" configuration). Needless to say the intention was all the partitions to have exactly the same letters under both OSes, needless to say Windows 7 has detected all of them in a completely different order which would not be a problem (as the non-system drives letters can be changed easily after installation) if it wouldn't have named it's system drive C: (meant to be F:), which I have no Idea how to change.

Is there a way to set the letter you want? I don't mind reinstalling Windows 7 from scratch if it is to be set at installation time or even configured in some text files on the installation DVD.

I have tried this way, but it renders the Windows 7 system desktop unbootable (gets stuck on "Preparing your desktop..." after "Welcome").

share|improve this question
1  
I believe thats just because of C: in paths of user profiles HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. You should also change all other occurences, simply in regedit find and replace. –  week Nov 10 '13 at 2:47
    
Perhaps. What I have actually tried was searching for all the files containing 'c:', but there are too many and many are obviously irrelevant. Would be great if all the drive letter references are in the registry and none anywhere else... –  Ivan Nov 10 '13 at 3:11
    
I have successfully done this way, @week (the only problem was there are thousands registry keys to modify and there is no automatic replace feature in the standard regedit). You can post your suggestion as an answer and I shall approve it as correct (Hashbrown's one looks a way prettier but I didn't test it). –  Ivan Nov 10 '13 at 14:39

2 Answers 2

up vote 0 down vote accepted

It's because old drive letter is defined in user profile settings in registry:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

You should also change all other occurences, in regedit simply find and replace.


But If it's in your realm of possibilities, then you should reinstall Windows with @Hashbrown's solution. It's the right way.

share|improve this answer

This should be achievable using the unattended install software (though this implies a reinstall).
When creating your image you should be able to choose the install's drive letter by configuring the appropriate answer file;

windowsPE -> *_Microsoft-Windows-Setup_neutral -> DiskConfiguration -> ModifyPartitions -> Letter

You'll need the WAIK to do this, and a here is a more explanatory guide (excuse the vulgar display picture of the helpful 'Jig-a-Bush').

As for using the image afterward there should be plenty of video's online.

share|improve this answer
1  
Thank you very much for your contribution, Hashbrown. Your answer looks great but I have already succeeded with @week's one (and it was handier in my case although it looks crappier). I will try your suggestion next time I need to install a multiboot system. The picture you've mentioned is totally Ok (actually I like it) but I adore you mentioning - perfect manners are always a joy to meet. –  Ivan Nov 10 '13 at 14:46
    
well I just thought that since stackexchange sites have such a low presence of imagery it might be confronting to professional users. Gotta warn 'em if they're at work or something –  Hashbrown Nov 10 '13 at 21:16
    
dont forget to give @week the big tick! –  Hashbrown Nov 10 '13 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.