Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hey all, I'm trying to switch up a home network from one computer (XP Service Pack 2) directly connected to via a modem to 2 computers (adding a Macbook) connecting through a router. The Macbook is connected wirelessly while the XP computer will (hopefully someday) have a wired connection (dual wireless/wired router).

The problem is that the XP computer won't connect through the router. Keep in mind that it connects just fine when hooked directly to the modem, so I don't think the network card is the problem. The issue is the title, for whatever reason it cannot seem to get an IP from the router. The error in the title is displayed when trying to run ipconfig /renew. Also keep in mind that the Macbook has no problems and is happily connected to the Internet. So, what I've tried so far:

The router is configured to be a DHCP server. The DHCP and DNS client services on the XP machine are both running and set to automatic. TCP/IP is set to obtain an IP address automatically.

ipconfig gives the following:

Connection-specific DNS Suffix :
Autoconfiguration IP Address : 169.254.172.217
Subnet Mask : 255.255.0.0
Default Gateway : 169.254.172.217

iprenew gives the error in the title

Anyway, any help would be greatly appreciated. If you need more info, just ask.

---EDIT--- If we assign a static IP for the wired windows machine, XP thinks that it's connected (limited or no connectivity disappears, and it says it's connected), but we are unable to access the web via a browser. We're also unable to ping the router. The make of the router is Belkin, and the make is N 150 Enhanced Wireless Router.

---EDIT--- No, the DHCP is not set to wireless only (there doesn't even appear to be such a setting).

share|improve this question
    
what does ipconfig, and ipconfig /renew say? –  Journeyman Geek Nov 8 '09 at 5:11

9 Answers 9

Try running ipconfig /flushdns to clear out the dns resolver cache, then ipconfig /release, then reboot.

Also make sure that your default gateway is set to the wireless router's address, before rebooting.

share|improve this answer

Are you sure you're joining the wireless network / getting wireless signal? Perhaps the router is in 802.11n only mode and you only have a "g" card in the XP machine.

Have the XP machine and router both been rebooted?

Can you assign the XP machine a manual IP address?

share|improve this answer

Questions I would ask if I were there:

  • What is the router make/model? Is there a firmware update?
  • Is the router's DHCP configured to only support the wireless connections for some bizarre reason?
  • Are you using the same cable when connecting to the router as when connecting to the modem?
  • If you manually set the IP address on your PC to one within the routable range, can you ping the router?

Any follow up questions would depend on the answers to the above...

share|improve this answer

I would start the ball rolling by giving the machine a static IP address on the same subnet as the router. Then pinging the router.

If possible to introduce yet another computer and see if that picks up an IP address from the router?

As other have mentioned, can you check the router's settings to see what IP addresses it's supposed to be giving out?

share|improve this answer

Sounds like an issue with the router. Have you checked the settings for MAC filtering? It's possible your XP machine's NIC is being blocked.

Also check that wired connections are enabled.

share|improve this answer
    
I had not checked that, but it appears that mac filtering is entirely off, so I think that it is unlikely that is the issue –  Derek Nov 8 '09 at 5:51

More questions:

  • Sorry, it wasn't clear to me: does the XP machine have a wired connection at this time?
  • The Macbook can connect to the router, but can it get out to the Internet?
  • When you set up the XP machine to work with that modem, did you install any software that was provided by the ISP?
  • Have you done the whole universal-home-networking-support-tech-fix-it routine? (1) power everything down, (2) wait a minute, (3) power on the modem and wait for it to connect to service, (4) power on router and wait for it to run through it's initialization, and (5) power on XP machine.
share|improve this answer

When you assign a static IP to the XP machine, what's the result of

route print

when you type that at a command prompt?

If you can't ping the router, there could be default gateway settings on the network card that are left over from the PPPoE connection, e.g. 68.76.25.12 or some such.

That's a guess, anyhow.

share|improve this answer

thts a known issue with some XP SP2 clients, theres a hotfix from microsoft which i cannot find the link rite now :( try to get it n update our system, hope that works out for you

http://support.microsoft.com/kb/928233#LetMeFixItMyselfAlways

share|improve this answer

It seems like the XP computer is set as its own gateway !
That way it can never connect to anything except itself.

I suggest that you :

  • Set the Startup of the DHCP & DNS services on the XP to manual, so they don't interfere
  • In the Properties of the wireless connection ensure that :
    1. IPv6 is unchecked
    2. The IPv4 Properties are set to auto-IP and auto-DNS.
share|improve this answer
    
The 169.254 address used for the IP is an APIPA address, not manually configured. It has no better choice to make for the gateway than itself, so that's what it shows. This is normal for a Windows machine set to use DHCP but failing to get an address. –  AdamV Nov 8 '09 at 8:22
    
@AdamV: Thanks for the explanation. However, my advice is valid and the above points do need checking! –  harrymc Nov 8 '09 at 8:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.