Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a proxy running that I can successfully use with both Firefox and Safari. However flash is less amiable and from what I read it will not use a system proxy unless if cannot connect directly. Is there a way on Mac OS X to force everything through a proxy. That is only allow the proxy access to the outside internet?

Edit:

Ran route this is what I got and then all internet stopped working even with the proxy running

Mac:~ user$ sudo route flush
Password:
default              xx.xx.xx.xx        done
route: write to routing socket: No such process
got only -1 for rlen
Mac:~ user$ sudo route add 127.0.0.1
route: writing to routing socket: Invalid argument
add host 127.0.0.1: Invalid argument

Then I launch TCPCatcher and run it on port 8200 with monitor SSL enabled and Transparent Proxy unchecked.

I then set my Proxy in System Preferences to 127.0.0.1:8200

After that I set firefox to use the System Proxy

I then attempt to connect to a website and it fails.

share|improve this question
    
Doesn't sound like "transparent proxy" is the right name for something that needs to be configured everywhere… – grawity Nov 10 '13 at 18:49
    
Sorry I guess it might not be I am rather new to it sense I'm so use to having an option for a proxy in most software. – Zimm3r Nov 10 '13 at 18:58

Remove all default routes (using the route command) and add one specifically for the proxy's IP address.

share|improve this answer
    
So like this... (proxy running on 127.0.0.1:8200) sudo route flush sudo route add 127.0.0.1:8200 – Zimm3r Nov 10 '13 at 19:05
    
@Zimm3r: Routes are added to the IP address – and the :port isn't part of that. – grawity Nov 10 '13 at 19:10
    
So wouldn't say https and http try different ports both of which aren't the proxy. – Zimm3r Nov 10 '13 at 19:11
    
Tried without the port and it still failed to work (not connecting to internet – Zimm3r Nov 10 '13 at 19:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .