Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Configuration:

  • windows 8 (desktop)
  • firefox (latest version)

I've been trying to figure out how to enable the checkbox to "always open with ... application for file type", for quite a while without any luck.

enter image description here

Can anybody explain to me how I can enable the checkbox (see red rectangle). It's in Dutch, but I hope you recognize the dialog.

Tried so far: - default programs (control panel) - HKCU/Microsoft/.../FileExts: remove the UserChoice (but it was already removed, so no luck there either)

Thanks a lot in advance

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It may not be easily possible. It is likely the Content-Type of the .torrent file at the site/server is set as a generic application/octet-stream MIME media type i.e. binary data that can be anything including .exe, .msi etc. So if Firefox were to enable that option then any subsequent files with the application/octet-stream MIME media type including programs, installers etc. would open in uTorrent which would be in the least undesirable. The correct MIME media type for .torrent seems to be application/x-bittorrent though it isn't officially listed here.

In Firefox, browse to the site, open Tools (Alt + T) > Web Developer > Web Console, Clear any current entries in the opened Web Console, and click on the download link for the .torrent file. Next, in the Web Console click on the GET link corresponding to the .torrent and look for the Content-Type under Response Headers.

Firefox Tools

Properly Configuring Server MIME Types

share|improve this answer
    
Hi, thanks a lot for the help, will try what you propose this evening! –  bas Nov 11 '13 at 8:09
    
No problem :) Please note that if the Content-Type shows application/octet-stream, then it may not be possible at all, unless perhaps a Firefox extension is used. –  vWil Nov 12 '13 at 4:02
    
Aye, you were right all along :). content type indeed is application/octet-stream. So maybe a different torrent site would solve this problem for me? –  bas Nov 12 '13 at 19:05
    
Yeah, found another site already. Hah! Thx a lot, this have been annoying me for quite some time now :). –  bas Nov 12 '13 at 19:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.