Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Hard disk, that worked yesterday but is no longer being recognized by BIOS. I think this is because I unplugged it while the computer was rebooting (I know this was stupid) and now I cant choose it as a boot option. However Ubuntu still recognizes the device and and I have since erased the drive using

dd if=/dev/zero of=/dev/sda bs=1M 

and then reformatted it by doing

sudo fdisk /dev/sda

and

sudo mkfs.ext3 /dev/sda1

I then installed Xubuntu 13.10 from a CD onto the hard drive. The installation works correctly but when I restart the computer I still cant boot into the hard drive.

When I type (while running the CD OS)

sudo lshw -C disk

I get

*-disk
    description: ATA Disk 
    product: WDC WD1002FAEX-0
    vendor: Western Digital
    physical id: 0.0.0
    bus info: scsi@1:0.0.0
    logical name: /dev/sda
    version: 05.0
    serial: WD-WMAW30714392
    size: 931Gib (1TB)
    capabilities: partitioned partitioned:dos
    configuration: ansiversion=5 sectorsize=512 signature=000d2121
*-cdrom
    ...
    ....

Also I'm pretty sure BIOS sees the drive because when I go to boot options it doesn't just say

Hard Disk

though that is an option, it says

Hard Disk:WDC WD1002FAEX-00Y9A0

and I'll set it to boot option #1 but unlike the CD in the boot device priority listing, the hard disk does not light up.

What could be causing this? What if anything can I do to try and resolve?

Thanks for any and all help.

share|improve this question
    
This is the first time I've ever heard of this happening. Have you tried plugging it into a different port on the motherboard, or perhaps resetting your BIOS? Both the soft in-BIOS method as well as a hard reset by taking out the battery and waiting for a few minutes. –  valsidalv Nov 11 '13 at 19:05
    
@valsidalv I've tried a different port and that didn't work but I don't think I've trie resetting BIOS. However I just tried adding a new boot option to boot device priority listing, the option being Hard Disk (even though it was already included) and the system restarted and booted into the hard disk. I have no idea why this happened but seems to be working now. –  Loourr Nov 11 '13 at 19:16
add comment

1 Answer

It sounds to me like the bios is working fine. I posit that one (or both) of 2 things are wrong -

  1. You have not set the disk bootable and the BIOS is looking for the bootable flag on the appropriate partition. Running fdisk and toggling the "bootable" flag with "a" for the appropriate partition might fix this.

  2. The bootloader was not installed into the appropriate place - maybe, for example, you booted off a USB disk and the boot loader was installed there ? To fix this, assuming you are using grub, you might be able to run grub-install /dev/sdX

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.