Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install a bootable kubuntu 12.04.3 LTS on my Kingston flash drive (1,9GB storage). I've already tried it twice so far and the flash drive didn't start from USB, although I made sure that BIOS has USB as the first setting (it's USB, DVD, HDD respectively).

I use usb-creator-kde. I read it is advised to format the flash drive entirely, so I click clear disk content (on the flash drive), then I get a dozen of options to install the system on:

enter image description here

What does it mean, what the heck is that? Just to make it clear - yes, I've got a single USB drive.

Pojemność = capacity, Wolne miejsce = free space.

share|improve this question

3 Answers 3

Try unmounting the partition and creating a new FAT32 filesystem on it, to be sure it's completely clean and empty. You can do it from graphical interface (see there for the howto) or from shell :

sudo umount /dev/sdb1
sudo mkdosfs -F 32 /dev/sdb1

You may also try an other bootable usb creator. I personally use Unetbootin, and it never failed me.

share|improve this answer

From the Arch Linux USB Installation Media manpage:

UNetbootin can be used on any Linux distribution or Windows to copy your iso to a USB device. However, Unetbootin overwrites syslinux.cfg, so it creates a USB device that does not boot properly. For this reason, Unetbootin is not recommended

Unfortunately this comment applies to other Linux distros, including Kubuntu (trust me, I am writing from Kubuntu 13.10). Instead, the recommended way to create a USB installation medium is to issue, as root, the following command:

 dd bs=4M if=/path/to/kubuntu.iso of=/dev/sdX && sync

sdX is your USB device. Three important caveats:

1) You will have to find out which one it is all by yourself, and you must be careful, because the above command, just like unetbootin or any such utility, will wipe everything off sdX.

2) it is /dev/sdb (if the drive letter is b), not /dev/sdb1.

3) The flash drive must be inserted but unmounted. If you have a system that automatically mounts USB pens, please use sudo umount ... to unmount the drive before dd'ing it.

The last command, sync, just flashes the file system buffers.

share|improve this answer

So I potentially recently had the same problem trying to make a bootable usb with Linux Mint off of a Linux Mint distribution on my desktop. The problem was that whatever usb creator comes stock with Mint wasn't installing a bootloader that was compatible with UEFI. If instead of BIOS you have a UEFI system this may be your problem. I solved it by installing the gnome version of start-up disk creator usb-creator-gtk.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.